Output drops on GRE tunnel interface

Unanswered Question
Sep 7th, 2007

We've experienced "output drops" on GRE tunnel interfaces with no IPSec. At first we suspected that it's caused by the outbound QoS policy but then we couldn't find any drops when we did a "show policy-map interface tunnel xxx". We've removed the service-policy command but still there're output drops. The WAN link for carrying GRE traffic is not even congested and the CPU utilization of the router is under 10%. The router model is a Cisco 7206VXR. The physical WAN interface is on the GE port on NPE-G1.

interface Tunnel1

bandwidth 20000

ip address 20.x.x.2 255.255.255.252

ip mtu 1440

ip multicast boundary MCAST-ACL

ip route-cache flow

ip tcp adjust-mss 1360

ip ospf network point-to-point

ip ospf cost 1000

qos pre-classify

keepalive 10 3

no clns route-cache

tunnel source GigabitEthernet0/3

tunnel destination 10.1.2.1

!

interface GigabitEthernet0/3

bandwidth 20000

ip address 100.1.2.2 255.255.255.252

ip accounting precedence input

ip accounting precedence output

ip route-cache flow

duplex full

speed 100

media-type rj45

no negotiation auto

no clns route-cache

max-reserved-bandwidth 100

!

R2#sh int t1

Tunnel251 is up, line protocol is up

Hardware is Tunnel

Internet address is 20.1.2.2/30

MTU 1514 bytes, BW 20000 Kbit, DLY 500000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive set (10 sec), retries 3

Tunnel source 100.1.2.2 (GigabitEthernet0/3), destination 10.1.2.1

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 00:00:02, output 00:00:01, output hang never

Last clearing of "show interface" counters 6d22h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1703

Queueing strategy: fifo (QOS pre-classification)

Output queue: 0/0 (size/max)

5 minute input rate 1000 bits/sec, 1 packets/sec

5 minute output rate 1000 bits/sec, 1 packets/sec

10734208 packets input, 6541019418 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

10374287 packets output, 3059318677 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

R2#

So what are the factors that can contrubute to the output drops of a GRE tunnel interface without any QOS strategies implemented on the tunnel interface?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Fri, 09/07/2007 - 23:46

Looking at the ratio of transmitted vs dropped packets it appears to be a pretty rare issue.

What I can think of are packets that are too large to be encapsulated in GRE but have DF set. You have lagerely ruled this out by setting tcp-mss but this parameter only applies to tcp-traffic.

Regards,

Leo

cdvnet Sun, 10/07/2007 - 23:20

Hi. Did you finally solve the issue cause i 'm now meeting same problem on a new mpls circuit.

Regards

Actions

This Discussion