Unable to dial 3 digit code 195 ( on CME )

Unanswered Question
Sep 10th, 2007

Right then, this issue has been trailing on for a long time now and the finger of blame has been going back and forth between ourselves and the Telco provider.


Our customer is setup with CME and has 4 ISDN BRI connections to the router, they can dial through to any internal/external numbers no problems, apart from this 195 number (which is a directory inquiries number for the blind)


Whenever this number is dialled, the response in the Q931 debugging is as follows..


Jul 25 11:17:12.546: ISDN BR0/2/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Calling num 300

Jul 25 11:17:12.546: ISDN BR0/2/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 195

Jul 25 11:17:12.546: ISDN BR0/2/0 Q931: TX -> SETUP pd = 8 callref = 0x3F

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x8A

Exclusive, B2

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0080, '300'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '195'

Plan:Unknown, Type:Unknown

Sending Complete

Jul 25 11:17:12.722: ISDN BR0/2/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xBF

Channel ID i = 0x8A

Exclusive, B2

Jul 25 11:17:14.086: ISDN BR0/2/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xBF

Cause i = 0x829C - Invalid number format (incomplete number)

Progress Ind i = 0x8288 - In-band info or appropriate now available


I've altered the plan & types of the dialled number to no avail.

The Telco provider advises they can dial this 195 number straight from the ISDN termination equipment no problem.


We currently have the following dial-peer configured to match this number ( before investigating it was set just to match any 3 digit number)



dial-peer voice 31 pots

trunkgroup ISDN-BRI

corlist outgoing CLASS-DIR

destination-pattern 9195

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

forward-digits all



The user would dial 9195, the leading 9 would the be stripped by the outbound translation-profile applied to the trunk group, then forwarded onto the Telco line as just 195 ( which they expect to receive)


Help :<

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Mon, 09/10/2007 - 03:17

You are sending the number correctly. The only thing that can possibly be "wrong" on your side, is that telco expects a different calling plan/type IE for this call, eg ISDN/national. Try configuring like that in the translation-profile, or ask telco about how do they want these parameters to be set.


If they can dial successfully with an ISDN phone connected to the same BRI as the router, you should be able to see that as well with debug.


Hope this helps, please rate post if it does!

rstevenson1 Mon, 09/10/2007 - 05:11

Unfortunately I've tried every available option for the type of call i.e National/International/network/reserved5 etc etc whilst keeping the call plan as ISDN.


Tried to get such information from the Telco, but all I get is strange looks.

Unsure what you mean about being able to see them making a test call to this number from the ISDN2e (termination equipment) box, as obviously they're connected straight to their lines and not our router.

davieshuw Mon, 09/10/2007 - 05:21

I've had a little difficulty with my forward-digits-all commands, try just using forward-digits 3, see if that helps. Does your 999/911 emergency call work?

rstevenson1 Mon, 09/10/2007 - 05:42

Calling 3 digit numbers does work Ok, the user has called through to 150 (number for main Telco in Britain) which rings out and picks up the other end perfectly fine.

So it doesn't appear to be a problem with us sending out 3 digit numbers.

davieshuw Mon, 09/10/2007 - 05:59

Ive just slung in :


dial-peer voice 5 pots

destination-pattern 9195

port 0/1/0

forward-digits 3

no sip-register


And got through to the lovley directory lady the other side. Have you tried removing all your group settings and cor list settings; just have a plain old dial peer without any of the trimmings to eliminate anything interfering with the call setup

rstevenson1 Mon, 09/10/2007 - 06:26

davieshuw,

How do you have the plan/type setup for this call? did it go through as unknown/unknown or?


Just tried with this basic config and came up with the same invalid number format error again.But I hand't altered the plan/type, so it went through as unknown/unknown

davieshuw Mon, 09/10/2007 - 06:54

I did a debug when i call 195 (via unknown/unknown) and it was successful. Is it something stupid like the call is being shoved out of the wrong port possibly?

rstevenson1 Mon, 09/10/2007 - 07:11

Well, theoritically there isn't a wrong port it can go out on.

But I had basically copied your dial-peer for this number, so therefore it was pushed out of bri0/2/0, which I have now tested with unknown/unknown and ISDN/National and still doesnt work.

Regardless of the actual dial-peer, I am also making Isdn test calls from the CLI ( sourcing from a specified interface) and still shows the same results, invalid number format...

Paolo Bevilacqua Mon, 09/10/2007 - 05:57

What I mean, can you ask them to come onsite and using a phone of their own, call 195 from you line.

Due the way ISDN BRI works, you *should* be able to see their call with debug ISDN Q931, even it the router is not involved at all in the call.

This should be easy to setup because normally NT1 equipment has two RJ45 connectors.


Note: in the trace you sent, type plan is unknown/unknown, not ISDN.

davieshuw Mon, 09/10/2007 - 06:02

Be aware that if BT CAN make that call, they'll charge you ?100 plus VAT for the privilege.. As they did when they came out to check my compand error :(

Paolo Bevilacqua Mon, 09/10/2007 - 10:47

That is a very reasonable suggestion that I didn't think about. 300 is clearly not a valid CLI.

rstevenson1 Tue, 09/11/2007 - 01:18

The CLI comes through fine, not as 300, but the full code. But regardless of this, the number - 195 does not need registration, so there would not be an issue with the sourced dialling number.

anderson-david Tue, 09/11/2007 - 01:57

Hi,

use this debug and see where it points ie it will tell you if its using the wrong dial peer etc


debug voip ccapi inout


Also could you post your config


I hope this helps


Dave

rstevenson1 Tue, 09/11/2007 - 02:23

I've attached the config.

To rule out the dial peers, ive been making isdn test calls from the router and still get the same invalid number format response.

The call gets out to the Telco, but its being rejected for some reason, as the user will get the "This number has not been recognised" BT message when dialling 195.

But, as the Telco says, testing 195 from the ISDN2e box on the wall, works Ok, so they dont want to know.





Paolo Bevilacqua Tue, 09/11/2007 - 04:05

How do they test? Do you have an ISDN phone to make test as well ? Or do the NT1 have analog lines for phones, you can call from there while keeping debug enable on the router.

Or anything else that can be done without being charged the 100 pounds :)

rstevenson1 Tue, 09/11/2007 - 04:34

The Telco is testing via an ISDN harrier tester, I don't have an ISDN phone, plus I am remote supporting this site, the site is based in Scotland, im in England..

Paolo Bevilacqua Tue, 09/11/2007 - 05:19

Ok, ask if the NT1 has analog lines (it should) to which they can connect a regular phone and try the call.

rstevenson1 Wed, 09/12/2007 - 00:37

The termination equipment at the customer site, doesn't have access for an analogue phone.

They have an external phone line onsite (has their fax connected) which connects to the same exchange, dialling 195 from here is successful.


rstevenson1 Mon, 09/17/2007 - 07:05

Any further suggestions on this issue?

Customer still unable to dial and Telco standing firm and happy with their line.

davieshuw Tue, 09/18/2007 - 01:34

Hey. Id phone BT back and get them to send an engineer out. It's 100 quid if they cant find a problem. The engineer will plug his isdn phone into the BRI socket, dial 195 and it'll either work or not. If it works, its the phone system, if it doesnt its BT's problem :)


Either way worth it to be sure.

rstevenson1 Tue, 09/18/2007 - 01:37

Davieshuw, they've already done this.

The BT engineer connected his ISDN harrier tester to the BT isdn2e box and could dial 195 perfectly fine.

Hence me raising this discussion on these forums, looking for help on the config/call setup side :D

Paolo Bevilacqua Tue, 09/18/2007 - 01:43

We would need to find which parameters are different when he places the call successfully.

Fore sure, one parameter is the calling number (what you are sending is invalid)

mamadubig Wed, 09/26/2007 - 14:41

I have a similar problem. 911 calls are failing. Our provider is claims we are not sending them the digits. Here is an extract from thier debug:


Sep 24 09:47:08.442 MDT: ISDN Se1/1:23 Q931: SETUP pd = 8 callref =

0x0930

Bearer Capability i = 0x8090A2

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98388

Exclusive, Channel 8

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0080, '261'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80

Plan:Unknown, Type:Unknown

Sep 24 09:47:08.446 MDT: ISDN Se1/1:23 Q921: Net TX -> RR sapi=0 tei=0

nr=8 Sep 24 09:47:12.442 MDT: ISDN Se1/1:23 Q921: Net RX <- INFO sapi=0

tei=0, ns=8 nr=89



My router configuration is:

!

dial-peer voice 911 pots

destination-pattern 911

port 0/0/0:23

!

dial-peer voice 9911 pots

port 0/0/0:23

forward-digits 3


Any ideas? Thanks in advance.


Paolo Bevilacqua Thu, 09/27/2007 - 02:52

Indeed you are not, add forward-digits all under DP 911.


Hope this helps, please rate post if it does!

Actions

This Discussion