1801 router

Unanswered Question
Sep 10th, 2007

Hi,

I was using old router with wireless sharing 7/8 computers and have got one static IP address from BT broadband ADSL line.I just bought new 1801 router and tried to set up the router setting as the instruction in the book.

I changed the IP address to 192.168.0.1 from 10.10.10.1 which is the default IP. so, now, I can see the router setting(SDM Express) as 192.168.0.1. But, I'm confused to set up in the WAN setting. I don't understand wheather to choose DHCP or static IP or others. I've already phoned to BT but, they said they can't help to set up with cisco routers. So, what am I going to do? please help me.

if someone can help me to configure the 1801 router, that would be great.

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
Paolo Bevilacqua Mon, 09/10/2007 - 03:24

Forget about SDM, is of little help and will prevent you from learning how things work.

Use putty or other good terminal program to telnet into the router and use the classic CLI.

Ask BT which "encapsulation" do they use on the ADSL, like which VPI/VCI, if PPPoE, PPPoA, rfc1481, static or dynamic addres, etc, and we will give you a config snippet that will work.

Paolo Bevilacqua Mon, 09/10/2007 - 04:59

Nice job by BT. install putty on PC or use windows telnet, then configure:

ip dhcp pool lan

network 192.168.1.0

default-router 192.168.0.1

dns-server 192.168.0.1

int atm0

no ip address

ip nat outside

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Dialer0

ip address 217.41.60.31 255.255.255.255 <-- REPLACE WITH STATIC ADDRESS or

ip address negotiated <--- if you have dynamic address

no ip unreachable

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username [email protected] password

ppp ipcp dns request

ppp ipcp route default

ip domain-lookup

ip dns server

Good luck!

peti2006_peti2006 Mon, 09/10/2007 - 08:17

I downloaded 'putty' and tried to set up the router. but, I got an error in putty.

1. In putty, I typed '192.168.0.1' (router IP) in hostname box. and clicked Open.

2. It appeared commend prompt with black background color.

3. I typed login username and password of the router.

4. and it asked me to type my name.

5. After I typed name and clicked enter , it displayed an error 'Unknown command or computer name, or unable to find computer address'

screen-shot of the error here.http://www.tamac.com/putty.doc

markmotors Mon, 09/10/2007 - 11:56

The yourname# is the router prompt... it says your name because you haven't configured a host name yet. A good way to start would be type a question mark "?" That will list all of the possible commands you can type. What you will need to do is configure your router from the global configuration mode. To enter this mode type "configure terminal" or "conf t". Note that typing "exit" or pressing ctrl+z will bring out to the previous mode.

A few commands you might want to start with from the yourname# might be...

yourname#sho run (This will show the current running config of your router.)

yourname#conf t (This will enter you into global configuartion mode)

yourname(config)#hostname myrouter (This will set the hostname of your router. I used myrouter, but you you can use any name.)

yourname(config)#exit (This will move you back out to privileged EXEC mode which looks like yourname#)

If you know nothing about the Cisco CLI you might want to try to find a book that walks you through getting to know the basics.

-Garrett

peti2006_peti2006 Tue, 09/11/2007 - 03:35

In putty, I typed one line by one line in global configuration mode.

Everything was fine and it didn't show any errors before I typed my static IP and subnet mask.

but, I got an error after I typed 'ip address 217.41.60.31 255.255.255.255'.

The error is 'Bad mask /32 for address 217.41.60.31

Do I need to connect with ADSL cable to router while I'm configuring the router in putty?

screen-shot of the error here. http://www.tamac.com/staticip.doc

Paolo Bevilacqua Tue, 09/11/2007 - 04:15

Whoop, my bad, forgot thet /32 is allowed for loopback interfaces only.

Try 217.41.60.31 255.255.255.0

peti2006_peti2006 Tue, 09/11/2007 - 23:45

now, i can see the router with the new IP- 192.168.1.1

but, I couldn't still access internet until I typed everything in putty.

just to want to make sure. I don't need to type this line - 'ip address negotiated' , if I type this line - 'ip address 217.41.60.31 255.255.255.0'. right ?

current configuration of the router here. http://www.tamac.com/shorun.doc

Paolo Bevilacqua Wed, 09/12/2007 - 11:24

Exactly, put that address instead of "negotiated".

Then do "show ip int brief", if you see a virtual-access interface up/up you're fine. Else there may be a problem with authentication, that BT doesn't specify if pap or chap.

markmotors Mon, 09/17/2007 - 06:40

Do you have your own dns server? I am assuming not. Right now there is no dns server configured in your config. Here is what I would try...

tamacrouter#ping 217.41.60.31

If that is successful your internet connection is most-likely up. If that fails try posting your tamacrouter#sho ip route

If the ping works and you dont have a dns server here is what I would do....

add a static default route... I think you will need one, someone please correct me if I am wrong...

tamacrouter#conf t

tamacrouter(config)#ip route 0.0.0.0 0.0.0.0 217.47.49.202

That will push all your traffic to your default gateway. Then it looks like you are going to need to add/remove a few things for nat...

First create an access list...

tamacrouter#conf t

tamacrouter(config)#access-list 5 permit 192.168.1.0 0.0.0.255

Remove your current ip nat inside source and add the correct one..

tamacrouter#conf t

tamacrouter(config)#no ip nat inside source list 1 interface ATM0.2 overload

tamacrouter(config)#no ip nat inside source list 5 interface Dialer0 overload

Last, fix your dhcp pool and your dns servers to your dhcp pool...

tamacrouter#conf t

tamacrouter(config)#ip dhcp pool lan

tamacrouter(dhcp-config)#default-router 192.168.1.1

tamacrouter(dhcp-config)#dns-server 194.72.9.38 194.72.0.98

One more thing you might want to do is add the dns server to the router so the router can do lookups...

tamacrouter#conf t

tamacrouter(config)#ip name-server 194.72.9.38 194.72.0.98

You should then be able to ping from the router...

tamacrouter#ping www.google.com

Please rate this post if it helped and Good Luck.

Actions

This Discussion