LMS 2.5: Topology View "Display View" Keeps Losing Configuration

Unanswered Question
Sep 10th, 2007

Hi all,

Since installing LMS 2.5 I've had this issue, which never occurred on our previous version of CiscoWorks. LMS 2.5 is installed on a brand new server - it isn't upgraded over our previous setup.

Issue: Campus Manager > Topology Services > Network Views > VTP Views > [ourVTPdomain] (Right-click) Display View

Previously I've spent a number of hours arranging the devices in the above view to suit my preferences. I always save the view continuously while arranging the devices so I don't have to start again. The problem is, whenever the server is restarted for any reason all my settings seem to get lost somehow and the view reverts to the default, unconfigured hierarchical view.

This has happened to me so often that I located the preferences files (NMSROOT\campus\etc\users\<myloginname> and copied them into a different folder in the hope that this would solve the problem. But it hasn't! I'm nearly ready to tear my hair out. When I copied the "user.preferences" file and the "nnn.xml" file back into the directory above I STILL got the default view as if I'd never changed the configuration.

I'd really be grateful if anyone could shed any light on what is causing this issue and how to resolve it because I find the visual representation of my network useful, but not the amount of time I have to waste redoing the layout every time there's a server restart.

Yours in desperation,

Ben.

[Late Edit]: I've just discovered that if I remove the "user.preferences" file from the above directory I don't get an error message - which I assume means that the app isn't even looking at my preferences file!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Mon, 09/10/2007 - 19:48

Exactly what version of Campus Manager are you using? Are you using a background image on your topology map?

ben_johnson Mon, 09/10/2007 - 20:11

Hi Joe,

CM 4.0.5. No background image, but I did change the background colour to black.

Cheers,

Ben.

Joe Clarke Mon, 09/10/2007 - 20:48

I cannot reproduce with Campus Manager 4.0.6 (update to LMS 2.6). However, when I changed my background from white to black, the map did relayout back to hierarchical. But, when I changed it, and saved it, the new layout persisted even across a reboot.

You might consider upgrading to LMS 2.6 (downloadable from Cisco.com), then apply the latest Campus Manager update to see if you have better luck.

ben_johnson Mon, 09/10/2007 - 21:15

There's no direct upgrade path from 2.5 to 2.6 (only from 2.5.1 to 2.6), and it would appear that 2.5.1 is not downloadable. And, unless I'm reading it wrong - there isn't even a direct upgrade path from 2.5 to 2.5.1. I'd have to do a fresh install and then migrate the data over to 2.5.1 and THEN upgrade to 2.6.

I'm sure the data migration would be less painful than the set-up-from-scratch scenario that I went through in May for 2.5, but just in case it's not I might hang out and see if my budget request for LMS 3.0 is approved for next year.

In the meantime I guess I'll just have to deal with not having a network map. Bummer!

Cheers,

Ben.

Joe Clarke Mon, 09/10/2007 - 21:28

You already have 2.5.1 (CM 4.0.5 is a patch on top of LMS 2.5.1), and there is a direct upgrade path from 2.5.1 to 2.6. Both 2.5.1 and 2.6 are freely downloadable from Cisco.com at http://www.cisco.com/kobayashi/sw-center/cw2000/lan-planner.shtml .

LMS 2.6 is essentially 2.5.2, so there is no data migration issues. It's just a big patch on top of what you already have. Once you have it installed, you can get the Campus Manager 4.0.9 update, then you should be seeing the results I'm seeing in my testing.

ben_johnson Mon, 09/10/2007 - 21:38

OK. I'll download the update to 2.6 and give it a try. I think I've updated all the other LMS components whenever an update was available so, given what you said earlier about CM 4.0.5, I probably have the 2.5.1 updates already.

Thanks Joe.

Ben.

ben_johnson Tue, 09/11/2007 - 21:37

Hi Joe,

I've done the upgrade to LMS 2.6. Unfortunately that's introduced another anomaly. When first starting up the server I can open Topology Services > ... > VTP and expand that node to see our VTP domain listed (but with no devices listed - which was at least consistent with LMS 2.5). However, after running a Major Acquisition and then doing a Data Collection our VTP domain is no longer available under the VTP branch. It's also not listed in the VTP Domains branch.

Layer 2 View still has a list of all devices.

I've stopped and restarted the crmdmgtd daemon and that made no difference.

Other new facets of LMS 2.6 seem to be quite useful (and functional), but I really want to get my network topo map running again.

Any suggestions?

Cheers,

Ben.

Joe Clarke Tue, 09/11/2007 - 22:12

Enable core, corex, and vlad debugging under Campus Manager > Admin > Campus Data Collection > Debugging Options, run a new Data Collection, and get the ani.log. Also, provide the name of the missing VTP domain.

ben_johnson Tue, 09/11/2007 - 22:40

Hi Joe,

As requested. VTP Domain is "SCUC". [Edit: The stuff appearing after the 2007/09/12 16:27 timestamp is what I did most recently]

Cheers,

Ben.

Attachment: 
Joe Clarke Tue, 09/11/2007 - 23:12

I see the domain deleted because it does not contain any devices. This also doesn't look like a full Data Collection. Clear out the contents of this log, then run another full Data Collection (start it for All Devices under Campus Manager > Home).

ben_johnson Wed, 09/12/2007 - 14:55

Hi Joe,

The data collection I did was for "All Devices" and not just "New Devices". However, I'll do as you've suggested above, double-check all my configuration settings and re-run a Data Collection in a blank ani.log and post it.

Cheers,

Ben.

ben_johnson Wed, 09/12/2007 - 15:24

Hi Joe,

ani.log attached as requested. Unfortunately there is some activity before I started the Data Collection, but just do a Find on "Ben" within the file and you'll end up where the Discovery started.

All configuration settings have been double-checked and seem to be correct.

Cheers,

Ben.

Attachment: 
Joe Clarke Wed, 09/12/2007 - 15:49

This is still not right. Please provide the ANIServer.log as well. I think you're hitting a bug.

Joe Clarke Wed, 09/12/2007 - 16:44

Looks like you're hitting CSCsk08540. I'll bet all the links on your layer 2 view are red as well. If you contact the TAC, a patch to fix this problem can be given to you. The workaround is to reinitialize the ANI database whenever the problem reoccurs.

ben_johnson Wed, 09/12/2007 - 17:07

Hi Joe,

Yes, the links in my Layer 2 view are all red. I've logged a job with our Cisco maintenance contractors to get the patch. Will post again regarding results.

Thanks for your help.

Ben.

ben_johnson Thu, 09/13/2007 - 21:59

Hi Joe,

I've done the workaround you suggested and that has worked for the moment. I'm too afraid to restart the server until our Cisco Maintenance contractor has come through with the patch. I've got the SCUC domain showing under the VTP link now.

Will update again once I get the official patch. They've contacted me twice but still not provided any patch.

Cheers,

Ben.

Actions

This Discussion