OSPF default route to internet

Unanswered Question
Sep 11th, 2007


I am having problem with configuring OSPF default route(connection to internet) on subnets which are not connected to ASA. I have following setup:

--internet-- ASA5505--Cisco Router---hosts



I can ping from both subnets all hosts except from subnet to internet.

Thank you and Kind regared,M

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Tue, 09/11/2007 - 03:40


You give us the information about the ASA and how it is configured to generate the default route. And that looks ok to me. It would help us a lot to understand the problem if you told us whether the routing table on your inside router has the default route or not.

I do see one thing that is problematic. I see configuration statements about network for NAT and split tunnel. But I do not see anything that tells the ASA where network is. I believe that you need a route statement that tells the ASA to use the inside interface to get to that network.



mocah Tue, 09/11/2007 - 11:21


first I would like to thank you for your help.

The strange thing was that all routes are in routing table of ASA and router. I have rechecked everything and I have found out that it is not the problem with routing, but ASA is blocking ICMP.

Thank you and kind regards,


Richard Burts Tue, 09/11/2007 - 12:45


I am glad that you got this figured out.

Thank you for posting back to the forum and indicating that you had solved the problem and what the problem was. It makes the forum more useful when people can read about a problem and can read about what solved the problem. This is a somewhat unusual and interesting problem. If I had asked you about the routing table on the ASA we would have figured out that the route was already in the routing table. I am not used to running a routing protocol on the firewall and did not think of this possibility. I hope I will remember this next time something like this comes up.




This Discussion