Two bonded circuits with same ISP on same router

Unanswered Question
Sep 11th, 2007
User Badges:

I currently have two different routers each with a bonded circuit to the same AS number using BGP. I want to combine them into one router. Can I have a neigbor statement with different ip's and the same AS number? Also, can I create a second loopback circuit in this same router? I have tried looking some of this up, but haven't found anything.


Thanks,


Tom


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 09/11/2007 - 07:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Tom


I am not sure that I fully understand your questions. But here are answers for what I think I understand. If they are not what you are expecting perhaps you can clarify the questions.


It is certainly possible to have 2 BGP neighbor statements for 2 addresses with the same AS number. This will work fine (assuming that the 2 addresses are 2 different routers for the same entity - it would serve no purpose to have 2 addresses that are on the same router).


I am not clear what you are talking about when you ask about a second loopback circuit in the same router. Can you clarify this?


HTH


Rick

tomswenson Tue, 09/11/2007 - 07:47
User Badges:

On one of my existing routers I have the following:



interface Loopback0

ip address 12.169.0.17 255.255.255.255


On the other one I have:


interface Loopback0

ip address 12.152.201.81 255.255.255.255


Would I just make on of them Loopback1 when I combine the routers?


So you say that there would be no problem with the following:


neighbor 12.123.198.142 remote-as 7018

neighbor 12.123.25.243 remote-as 7018


in the same Router BGP section?


Tom



Richard Burts Tue, 09/11/2007 - 07:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Tom


Since I am not familiar with your environment there is some chance that my answers might not be entirely correct for your situation. But I understand why each router had its own loopback interface (and its own IP address on that interface). I do not see any reason why you would need (or want) 2 loopback interfaces when you combine the routers. (and I assume that your original question about 2 loopback circuits was really about 2 loopback interfaces?)


Having

neighbor 12.123.198.142 remote-as 7018

neighbor 12.123.25.243 remote-as 7018

in the same router bgp section should work just fine (assuming that these are in fact two different routers and not two interfaces on the same router). And this assumes that both of those addresses are reachable from your router.


HTH


Rick

tomswenson Tue, 09/11/2007 - 08:03
User Badges:

When I set up a NxT1 circuit, I was given the instructions to setup a loopback circuit with this address. I don't really know what it does, but I currently have one on each router. I currently have a 2xT1 on one router and a 4xT1 on the other. I want to move the 2xT1 over to the router with the 4xT1.


Tom

Richard Burts Tue, 09/11/2007 - 09:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Tom


Would I understand correctly that your NxT1 circuits are configured with ip unnumbered which points to the loopback interface?


If so it probably makes sense and would work fine to have interface loopback 0 and interface loopback 1 and to have each NxT1 point to one of the loopbacks.


HTH


Rick

tomswenson Tue, 09/11/2007 - 11:30
User Badges:

As I mentioned before, I never figured out how the loopback was ever working. They just told me what to put in and it worked. There is no reference to the loopback address or the loopback port anywhere in the config. I figured it got referenced on there end. Here is my config of loopback and serial ports for my 2xT1:


interface Loopback0

ip address 12.152.201.81 255.255.255.255

!

interface Serial0/0

ip address 12.126.89.26 255.255.255.252

ip virtual-reassembly

encapsulation ppp

!

interface Serial0/1

ip address 12.126.89.22 255.255.255.252

ip virtual-reassembly

encapsulation ppp


Tom


tomswenson Tue, 09/11/2007 - 12:30
User Badges:

I started to do the config for this switchover and found that I don't have enough memory to create another set of T1 ports in the 3725 (where my existing 4xT1 is). I'm guessing this won't work at all and I have to buy a new box anyway. Thanks anyway. I did learn something.


Tom


Richard Burts Tue, 09/11/2007 - 13:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Tom


If there is not enough memory for the extra interfaces then probably a new router is the best answer.


I am glad that you have learned from this experience. I suspect that with the new router that similar questions will come up. If you want to post the config from the routers we can take a look at it and can perhaps give you some suggestions about what you might need (either for the existing routers or for the new router - especially as concerns the loopback interface and the serial interfaces).


HTH


Rick

Actions

This Discussion