Edit Exchange server after move

Unanswered Question
Sep 11th, 2007

I had several users that had their Exchange account moved to a different store, and lost the ability to listen to messages until I re-ran the permissions wizard.

I also have one user that was moved to a different mail server prior to the permissions wizard being run. I have since run the wizard, but in the Exchange Information section of the Profile page in Unity for this user, the old Exchange server still appears. Can this be edited at all? Do I have to delete and re-create the Unity mailbox for this user?

thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ginger Dillon Tue, 09/11/2007 - 10:28

Hi Joe -

Typically this field is corrected by replication with AD and the UnityDb database. There is a way to force replication to occur by adjusting a value in the UnityDB for the subscriber, if you feel comfortable doing so, meaning you will edit the SQL table directly. So be careful or check with TAC beforehand. Go into SQL - Enterprise Manager and drill down to the UnityDB database. Click on Tables. Right-click the Subscriber table and select Open all rows. You can query the subscriber's alias or just look for the subscriber. The column is called ObjectChangedId. Change the value to 0 (zero) and exit. This will force replication from AD back to Unity. I suppose you could change the home server name field for the subscriber, but I prefer the replication method. This should prevent you from having to delete/recreate the user in Unity, but of course this would work as well.

Ginger

joe.ainsworth Tue, 09/11/2007 - 11:08

Ginger,

I don't know that I put the actual problem in the message. This user cannot listen to messages via the phone, only Exchange. While forcing an AD sync might fix the display problem, will it also fix the root of the problem?

Thanks for the response.

Ginger Dillon Tue, 09/11/2007 - 11:52

Hi -

Yeah, this sounds like a different problem. Were there any errors when you moved the user's mailbox? What is Unity posting to the application event log when the user attempts to use the TUI or are you seeing any error messages? I would check the user's security permissions under Advanced Settings in ADUC MMC console and ensure inheritance is checked so the unitymsgstoresvc account can get access to the inbox. If inheritance is checked OK, and you did not observe any errors when moving the mailbox to the new information store, you might consider moving the user's mailbox back to its original server store location and re-test the TUI. If that works OK, try moving the mailbox back to the new information store and allow time for replication.

Ginger

joe.ainsworth Tue, 09/11/2007 - 12:35

Ginger,

After deleting and re-creating the mailbox, it appears that the issue is resolved. Best I can tell is that a new Exchange server was put on line, and at least 2 users moved to it prior to the Permissions Wizard being run again. I believe that was the root of the problem.

Thanks for the input.

Joe

Actions

This Discussion