How to troubleshoot this multicasting problem?

Unanswered Question
Sep 11th, 2007

I have 2 Sunray servers that need to use multicasting to communicate keep-alives. Between the 2 servers, there are 4 Layer3 6509 switches (distribution1-core1-core2-distribution2). All have multicating routing enabled and running PIM spare-mode on all Layer3 interfaces. The 2 core are configured as RP router and MSDP peering each other.

The servers use multicast address I can see the address in "sh ip igmp group" on both sides, however on one distribution switch, I have the following:

distribution2#sh ip pim rp is not a sparse-mode group

distribution2#sh ip pim autorp

AutoRP Information:

AutoRP is enabled.

PIM AutoRP Statistics: Sent/Received

RP Announce: 0/0, RP Discovery: 0/0

Seems that distribution switch can't discovery its RP (supposed to be the core on that side). How to troubleshoot the issue?

Thanks a lot


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ybajpai Tue, 09/11/2007 - 12:11

with the limited information i have form you, i think you have fallen for the classic auto rp catch22 situation viz. autorp is used to disperse RP information for PIM sparse mode but autorp itself uses dense mode multicasting for its protocol operation.

confirm that all L3 interfaces have one of the two options:

1) change PIM to pim sparse-dense mode instead os sparse-mode


2) the later IOS will let you use ip pim autorp listner command to enable the routers to run dense mode for autorp even if the interfaces are configured with only sparse-mode.



gwhuang5398 Fri, 09/14/2007 - 06:22

Thanks Yash. I'll try with "ip pim sparse-dense mode" on that vlan interface. Should I use it on all other layer 3 interfaces as well such as links to other layer switches?

The swithes (Sup720-3B) are running IOS 122-18.SXF7. I'll look up that autorp listen command.

What are some good tools or commands I can use to troubleshoot without turning on debug?

One more question: if "sh ip pim rp mapping" shows nothing in the output, what would be the problem?



nambi_gct Fri, 09/14/2007 - 06:37

Hi Gary,

Yes.You should enable pim on all the l3 interfaces.Most of the time you can troubleshoot with simple show commands.

Some of the key points that you need to remember are,

1) rpf neighbor should be a pim neighbor.

2) your rp should be reachable.You will not see any output with "show ip pim rp mapping" if rp is not reachable.

3) "show ip rpf" is another useful command when you see packets being dropped due to rpf failure.

These links will definitely be helpful to you.




This Discussion