Session timeout not working

Unanswered Question
Sep 11th, 2007
User Badges:

Hey gang-

I'm Hyperterminal-ing in to my 2811 router via the console port and the router keeps logging me off and dumping me out to user mode after a few minutes of inactivity. I'd like it to leave me in for an hour or more before doing so; I'm studying and it's a pain to have to keep re-logging in. I've tried the "session-timeout" parameter in Line Con 0 mode; it seems to have no effect. Any idea what the right command is?


Thanks much-

Dave S.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 09/11/2007 - 13:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Dave


If you want to stay logged in for 1 hour then this is what you need:

line con 0

exec-timeout 60


exec-timeout is an inactivity timer and is very different from the session timer (as you have discovered).


HTH


Rick

dshinnick Tue, 09/11/2007 - 13:44
User Badges:

Ah, thank you so much! I'll have to do yet more research and figure out the difference.


thanks again-

paul.matthews Wed, 09/12/2007 - 00:15
User Badges:
  • Silver, 250 points or more

exec-timeout is indeed the one you need, but setting it to long values can be a security risk if you forget to log out and just disconnect.


Setting to an hour means that if you don't logout and you have been in enable mode, there is a window of an hour from the last thing you type where someone can connect and have full access to the config of the router.


That means they can compromise the passwords, potentially for the whole network.


While I understand that it is inconvenient, and it may just be a lab network but it is a bad habit to get into, as it can easily find its way into your personal script that you add to every device when you first start to configure it - you know the one - setting password encryption, timestamping and no ip domain-lookup...


P.

Actions

This Discussion