VPN and MAC 10.4 Internet Problem

Unanswered Question
Sep 12th, 2007

I am running a PIX 506E using it for VPN access through a DSL modem. The modem is in passthrough and the PIX is taking VPN connections with no issues. All my clients can use local resources on the network, etc.

My Windows clients can ALSO surf the Internet while connected because I did the whole split-tunneling thing. My MAC 10.4 clients, however, cannot. One interesting issue is that the MAC clients can access the Internet through IP, which leads me to believe its some kind of DNS issue. But if it was, why do the Windows computers work?

I checked here on NetPro and found someone that said the split works well through the AirPort card, but not the Intel NIC. In my case the AirPort does NOT work well either.

I'm not sure what I'm doing wrong since all my Windows clients can do everything and the MAC clients can do everything except surf their local Internet unless they type the IP directly into the browser.

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
irisrios Tue, 09/18/2007 - 06:26

Manually type in the DNS address into the Mac client. DNS could either PIX local interface address to which Mac client is connected or the DNS address assigned by ISP to PIX through the modem.

leo.negron Tue, 09/18/2007 - 06:37

Oh thanks for replying. I had already found the answer. I had to stop my PIX from pushing DNS to the VPN because in 10.4 the file /etc/resolv.conf kept being overwritten with the new DNS. Since I don't need to VPN DNS because I am not routing Internet through the corporate network, I was able to take the command off.

It works fine now for both Windows and MAC OS. Thanks again!


This Discussion