switchport host command results in "portfast failed for Gix/x"

Unanswered Question
Sep 12th, 2007

I have 4 6509-E switches all the same configuration/hardware/revision/IOS levels. 1 switch fails (all WS-X6748-GE-TX) when "switchport host" command is enters on an interface range. Although a "show run" shows that all interfaces have portfast configured. What is causing this CLI output? don't know if the switch ports work, the switches are not yet deployed.

switch(config-if-range)#switchport host

switchport mode will be set to access

spanning-tree portfast will be enabled

channel group will be disabled

"portfast" failed for Gi3/1

"portfast" failed for Gi3/2

"portfast" failed for Gi3/3 etc.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
fred.mancen Wed, 09/12/2007 - 11:17

When you have a port channel configured on a range of ports, you cannot set these same ports to switchport host mode, because you can face STP loops. It just will work if the ports are not members of a channel group, that is why the switch disables the channel group.

Regards.

ra.peters Wed, 09/12/2007 - 11:39

Module 1 and 2 are in port-channels, I did not apply "switchport host" to those...it was on modules 3,4,7,8,9. All those are setup for server interfaces, which need portfast enabled. No port-channels were configured on those modules. I used the same configuration on 3 other switches without issue...

fred.mancen Wed, 09/12/2007 - 12:03

Sorry, buddy...I did not pay enough attention on it. Looking at the 6500 white paper, I found the line:

"During fast switchover to the standby supervisor engine, all channeling ports are cleared on its channeling configuration and state, and the links are pulled down temporarily to cause partner ports to reset. All ports are reset to the nonchanneling state."

As you are using two sup 720, this may be a message when sinchronizing the config between the supervisors, maybe it is just a sinchronization advise...I did not found further info on the web page search engine about this issue. But I can remember when setting up a 6513 using the switchport host command and faced messages like these. I will research further and as soon as I find something I will post it.

Regards.

ra.peters Wed, 09/12/2007 - 12:12

OK, thanks Fred. I did try searches on cisco.com and google for this type of error, but nothing obvious was seen. I did try the command several times on the same module with the same error message, so I don't think the sups were always syncing. I rebooted the switch (not in production yet) and tried the command again...same results.

Actions

This Discussion