QoS on New Cisco 3825 Router

Unanswered Question
Sep 13th, 2007

I recently replaced a Cisco 3640 Router with a new Cisco 3825 Router. We use multiple T-1 Circuits (IMA) for WAN connectivity.

The partial configuration for the ATM setup is as follows:

interface ATM1/0

description ATM CIR 1

no ip address

atm vc-per-vp 256

no atm ilmi-keepalive

ima-group 0

no scrambling-payload

!

interface ATM1/1

description ATM CIR 2

no ip address

atm vc-per-vp 256

no atm ilmi-keepalive

ima-group 0

no scrambling-payload

!

interface ATM1/2

description ATM CIR 3

no ip address

atm vc-per-vp 256

no atm ilmi-keepalive

ima-group 0

no scrambling-payload

!

interface ATM1/3

description ATM CIR 4

no ip address

atm vc-per-vp 256

no atm ilmi-keepalive

ima-group 0

no scrambling-payload

!

interface ATM1/IMA0

no ip address

no ip route-cache cef

atm vc-per-vp 256

no atm oversubscribe

atm uni-version 3.1

no atm auto-configuration

no atm ilmi-keepalive

no atm address-registration

no atm ilmi-enable

!

interface ATM1/IMA0.44 point-to-point

ip address 111.222.333.444 255.255.255.252

pvc ABC 1/44

vbr-rt 6000 6000

oam-pvc manage 0

encapsulation aal5snap

service-policy output IPATMCOS

I have a policy-map assigned under pvc on Interface ATM1/IMA0.44.

On the new Cisco 3825 Router, I have the following configuraton:

interface ATM0/IMA0

no ip address

no ip route-cache cef

no atm oversubscribe

atm uni-version 3.1

no atm auto-configuration

no atm ilmi-keepalive

no atm address-registration

no atm ilmi-enable

service-policy output IPATMCOS

!

interface ATM0/IMA0.44 point-to-point

ip address 111.222.333.444 255.255.255.252

pvc ABC 1/44

vbr-rt 6000 6000

oam-pvc manage 0

encapsulation aal5snap

!

!

interface ATM0/0/0

description WAN CIRCUIT 1

no ip address

no scrambling-payload

ima-group 0

no atm ilmi-keepalive

!

interface ATM0/0/1

description WAN CIRCUIT 2

no ip address

no scrambling-payload

ima-group 0

no atm ilmi-keepalive

!

interface ATM0/1/0

description WAN CIRCUIT 3

no ip address

no scrambling-payload

ima-group 0

no atm ilmi-keepalive

!

interface ATM0/1/1

description WAN CIRCUIT 4

no ip address

no scrambling-payload

ima-group 0

no atm ilmi-keepalive

When I attempt to add the Policy-Map IPATMCOS under Interface ATM0/IMA0.44, the line does not show up in the configuration.

Is there a change in 12.4 related to the placement of the Policy-Map?

I've placed the Policy-Map under Interface ATM0/IMA0, but this has no effect.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Thu, 09/13/2007 - 05:10

Don't know if this is your issue, but I've hit the situation where if the policy map has more bandwidth defined in it then it believes the interface supports, it will allow you to enter it at the command line, but quietly drops it (although I think I've also found it will syslog the drop).

I've also seen this behavior with any type of bundled links, if the bundle loses enough members that the bandwidth is insufficient for the policy, it gets dropped. (Policy doesn't automatically reappear when the down link member comes back on-line, either.)

If this is the issue, use bandwidth percentages, available in later IOSs, instead of absolute values, including for LLQ if defined.

Joseph W. Doherty Thu, 09/13/2007 - 05:47

Nothing in syslog then?

PS:

Forgot to comment on the question about policy placement with 12.4 and ATM.

Got lots of them working on many 2811 running 12.4 and ATM under the PVC, where you would expect to place it.

Actions

This Discussion