Drop in speed

Unanswered Question
Sep 13th, 2007

We just went to a 10Mbps pipe, which comes through the ISP's fiber box to an ME3400. From there, there is an Ethernet connection to a 2850 screening router. When I plug a laptop directly into the 3400 or into the inside interface of the 2850, I get 11Mbps consistently from many speed test sites. Once I plug the inside interface into a Catalyst 2950, the speed at any of the ports drops to less the 2Mbps or even below 1Mbps. Both the port on the 2950 and the 2850 are set to 100 Full. Here is the configuration for the switch:

Current configuration : 3227 bytes

!

! Last configuration change at 12:17:52 CDT Wed Sep 12 2007

! NVRAM config last updated at 08:03:38 CDT Tue Sep 11 2007

!

version 12.1

no service pad

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname XXX

!

no logging console

enable secret

enable password 7

!

clock timezone CST -6

clock summer-time CDT recurring

ip subnet-zero

no ip source-route

no ip domain-lookup

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

description Connection to New/Upgraded OSR

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/2

description Connection to Master NetScreen Firewall (PFX-LCLNSC01)

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/3

description Connection to Backup NetScreen Firewall (PFX-LCLNSC02)

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/4

description Reserved for Future Use

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

!

interface FastEthernet0/5

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

!

interface FastEthernet0/6

switchport mode access

no ip address

duplex full

speed 10

no cdp enable

!

interface FastEthernet0/7

description Unknown Device (Unknown IP)

switchport mode access

no ip address

duplex half

speed 10

no cdp enable

!

interface FastEthernet0/8

description Unknown Device

switchport mode access

no ip address

duplex half

speed 10

no cdp enable

!

interface FastEthernet0/9

description Web Camera

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

!

interface FastEthernet0/10

description FTP Server

switchport mode access

no ip address

duplex half

speed 10

no cdp enable

!

interface FastEthernet0/11

switchport mode access

no ip address

duplex half

speed 10

no cdp enable

!

interface FastEthernet0/12

description Connection to new Router

switchport mode access

no ip address

duplex full

speed 100

no cdp enable

spanning-tree portfast

!

interface Vlan1

ip address 74.143.XX.XX 255.255.255.224

!

ip default-gateway 74.143.XX.XX

no ip http server

!

access-list 1 remark

access-list 1 remark -- Permit Telnet from virtual IP address of locations Netscreen FW.s to OSR

access-list 1 permit 74.143.XX.XX

access-list 1 deny any

access-list 2 remark

access-list 2 remark Permit MOC Solarwinds Server Access

access-list 2 permit 159.54.XX.XX

access-list 2 deny any

no cdp run

snmp-server community

snmp-server community

!

line con 0

password 7

line vty 0 4

access-class 1 in

password 7

login

line vty 5 15

access-class 1 in

password 7

login

!

ntp clock-period 17180043

ntp server 159.54.XX.XX

end

The default gateway is set to point to the inside interface of the router.

I have talked to various people but nobody can give a definitive answer. Thanks for any help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jahilnt10 Thu, 09/13/2007 - 12:04

Do you get packet drops if you ping to router and on wards? Are there multiple routes for same destination? Do you use policy routing or rate limit things?

I don't think there is an issue with switch, better if you can paste router configuration.

spremkumar Thu, 09/13/2007 - 21:34

hi

did u try doing simultaneous downloads from different sites and check out for the max utilisation as well as the speed you get on the link ?

regds

avmabe Fri, 09/14/2007 - 10:50

Also keep in mind speed test sites are not accurate.

twicky61rrs Fri, 09/14/2007 - 10:53

Actually I finally solved all of it this morning. Turns out that I had to set SOME of the interfaces to Auto duplex and speed. Took a while to find the right combo but it all works not. Thanks for everyones help.

Actions

This Discussion