L2TP Tunnel between LNS and RAS

Unanswered Question
Sep 13th, 2007

Can anyone help:

- how can I form a L2TP tunnel between RAS and LNS without a PRI connection to RAS. I want to simulate a L2TP tunnel and get it authenticated locally on LNS.

- Once L2TP tunnel is formed and authenticated, how can I associate to the respective VRF.


Regards

BSN

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bharat Negi Wed, 09/19/2007 - 22:05

Hi


Thanks for the reply. I have pasted the configs of RAS and LNS below. Can you suggest changes. This is the curren configuration and not working. PPPoE session is getting established but not L2TP tunnel.


RAS:

vpdn-group 1

request-dialin

protocol l2tp

initiate-to ip 10.10.10.1 >>>Loopback of LNS

local name RAS

l2tp tunnel password 0 cisco

!

vpdn-group 2

accept-dialin

protocol pppoe

virtual-template 2

l2tp tunnel password 0 cisco

!

username cisco password 0 cisco

!

interface Loopback100

ip address 10.10.10.2 255.255.255.255

!

interface GigabitEthernet0/0 >>Conn to Fa2/1/1 of LNS

ip address 10.10.20.1 255.255.255.0

pppoe enable

!

interface Virtual-Template2

ip unnumbered Loopback100

peer default ip address pool test

ppp authentication chap callin

!

ip local pool test 10.10.20.2 10.10.20.10

!

ip route 0.0.0.0 0.0.0.0 gig 0/0



LNS:

vpdn-group 10

accept-dialin

protocol l2tp

virtual-template 1

terminate-from hostname RAS2

source-ip 10.10.10.1

l2tp tunnel password 0 cisco

!

username cisco password 0 cisco

!

interface Loopback100

ip address 10.10.10.1 255.255.255.255

!

interface FastEthernet2/1/1 >>Conn to Gig0/0 of RAS

ip address 10.10.20.2 255.255.255.0

!

interface Virtual-Template1

ip unnumbered Loopback100

ppp authentication chap

!

ip route 0.0.0.0 0.0.0.0 FastEthernet2/1/1

Actions

This Discussion