Virtual Memory Usage % High

Answered Question
Sep 14th, 2007
User Badges:

Hi Guys we have 3 CCM servers one publisher and two subscribers.


Virtual memory is running at 80% on the publisher and about 60% on the subscribers.


I keep getting the below alerts.


Should I be overly worried about this alerts? And if so what action should I take?


On Fri Sep 14 12:20:28 BST 2007 on node 10.52.224.10.

Available virtual memory below 30 Percent.

dbmon (1127 MB) uses most of the memory.

Correct Answer by Yorick Petey about 9 years 8 months ago

Hi,


did you resolve this issue?

I am experiencing the same with a CCM cluster (CCM 5.1(1b)).

Thank you.


Yorick Petey

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Chris Deren Fri, 09/14/2007 - 05:32
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

What version of CM?

connollyn Fri, 09/14/2007 - 05:37
User Badges:

System version: 5.0.4.2137-3

Administration version: 1.1.0.0-1

Correct Answer
Yorick Petey Thu, 11/15/2007 - 01:11
User Badges:

Hi,


did you resolve this issue?

I am experiencing the same with a CCM cluster (CCM 5.1(1b)).

Thank you.


Yorick Petey

connollyn Mon, 11/19/2007 - 03:02
User Badges:

Hi Yorick,

We have resolved this issue now. We rebooted the publishing server.


If the virtual memory keeps increasing on the publisher server you will lose services such as extension mobility and will be unable to update phones.


Since the reboot publisher virtual memory is holding steady.

cristian.munoz Mon, 10/06/2008 - 11:50
User Badges:

Hi


I have the same problem in a cluster of 4 CCMs. The symptoms are web acces fail y Corporate Directory fail. I check the RTMT and i see the virtual memory are 98%. Time ago i have tha same problem and i solved rebooting the publisher. The version is 5.1.3.1000-12. Who knows the final fix?

gogasca Mon, 10/06/2008 - 12:49
User Badges:
  • Green, 3000 points or more

Hi cristian,

5.1.3.1000-12 we have some problems with our Webapps impacting Tomcat.

It highly recommended to upgrade at least to 5.1.3c

Yorick Petey Mon, 10/06/2008 - 13:11
User Badges:

Hi everybody,


we are even experiencing the high virtual memory issue on a 6.1.2 cluster (3 nodes), exclusively with one of the nodes.


Guys, can you check in RTMT the Calls in progress counter? Because on the node with high VM alerts, the Calls in progress statistics are constantly growing, never released.


Thank you.

volkovvalery Wed, 10/22/2008 - 05:09
User Badges:

We have the same problem!

Two servers in cluster. On Publisher Virtual Memory Usage increase every day on 2-3 %.


System version: 6.1.1.2000-3

Yorick Petey Wed, 10/22/2008 - 10:50
User Badges:

Hi volkovvalery,


Are you using a voice gateway with QSIG protocol?


Yorick

Yorick Petey Wed, 10/22/2008 - 23:28
User Badges:

Is it a MGCP controlled gateway? What is on the other side of the ISDN line, the telco?


Go to Serviceability/Tools/Serviceability Reports Archive, select the last PDF report for PerformanceRep, and try to upload Call Activity and System Resources utilization graphs.


Thank you.

volkovvalery Thu, 10/23/2008 - 00:01
User Badges:

Yes, MGCP and telco.

What i'll see on this graphs?

How i can resolv my problem?

May be increase the memory on MCS-7825H3?

Yorick Petey Thu, 10/23/2008 - 01:09
User Badges:

I would see especially the call activity graph, to see if the Calls in Progress counter is constantly growing up. It's our problem and we are currently troubleshooting this with TAC.

qpippen Tue, 12/02/2008 - 05:51
User Badges:

Hi,


I have the same issue with the call in progress that keep growing without legit reasons... How did you resolve your issue ?


We are using CCM 6.1


Yorick Petey Tue, 12/02/2008 - 06:29
User Badges:

Hi,

Unfortunately, the issue is still not fixed. A case is opened for a lot of months, but Cisco does not catch the root cause.

Please keep us updated if anyone find a cause.


Thank you.


Yorick

qpippen Tue, 12/02/2008 - 06:36
User Badges:

ok thanks!


does a reboot of the machine fix the problem temporally until it grow up again ?

Yorick Petey Tue, 12/02/2008 - 06:39
User Badges:

Exactly, we have 2 installations with this issue. One under 6.1.2, the other under 5.1.1.

Both have E1 QSIG/MGCP GW. But other installations without the problem have E1 QSIG MGCP Gw too...

qpippen Tue, 12/02/2008 - 06:53
User Badges:

look at this


CSCsv64565


this might be our problem we are running on 6.1.1120


got this from the rss hot tac issue



Yorick Petey Tue, 12/02/2008 - 07:48
User Badges:

Well seen!

This bug is indeed interesting. The issue would occur with the CallBack feature from remote site through QSIG.

But, in our situation, the calls in progress graph is growing up linearly, and I am pretty sure users don't use CallBack every minute, including nights and week-ends ;).


Actually the engineer handling our case saw the Cdcc process crashs too, but not the cause.

What I am thinking is, there is another QSIG cause for the subprocess Cdcc crashs... I will push your bug id to TAC.


Thank you for this help! Very interesting.

Best regards,


Yorick

Yorick Petey Tue, 12/02/2008 - 14:09
User Badges:

Additionally, I found this bug CSCsk60495, related to similar behavior with Path replacement. And indeed, this feature is implemented between our Cisco cluster and the Siemens PBX. It's a good way to troubleshoot in, we will try to disable path replacement.


Yorick

Same was the issue I was facing and found the same bug ID. Spent sleepless nights with Cisco TAC, who did anatomical study deep in to the OS level, found the bug ID and finally suggested to upgrade the cluster from 5.1.2 to 6.1.2.


Just check again and found that we haven't faced the same problem (High VM %)for over 11 months since then.


Regards,

Ashish

Yorick Petey Thu, 12/04/2008 - 13:28
User Badges:

Hi Ashish,


The fact is we already are in 6.1.2, meaning there is surely another bug related to MGCP QSIG gateways...

I will try to disable Path replacement.

strick_9 Fri, 02/05/2010 - 07:42
User Badges:

I know this shows closed but i am still haveing this issue, running CCM

System version: 6.1.2.1116-2
Pub and Sub
DS3 between them
Pub Virtual Memory continues to rise, eventually i have to reboot the PUB
Any one ?
Yorick Petey Wed, 02/10/2010 - 07:53
User Badges:

Hi strick,


What kind of telco/interPBX links do you have? Any QSIG line with a legacy PBX?

Actions

This Discussion