1811 Switch capabilities

Unanswered Question
Sep 14th, 2007

Hello all

How do I extend fa0 subnet to the 8 switch ports. I would like to have 1 wan port, and 9 lan ports. Kind of like a $50 linksys router you would buy at walmart.

Thanks for your time

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
wochanda Fri, 09/14/2007 - 15:16

I've forgotten how the port numbering here goes, but I believe we have Fa0 to Fa9. 8 of these ports are layer-2, meaning the only commands accepted are 'switchport access vlan ', and the other is a layer-3 interface, meaning you can configure an IP address directly on it. Assuming Fa0 is the "wan" port, your configuration would look something like this:

ip dhcp pool Private

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

import all

interface fa0

ip address dhcp

ip nat outside

interface range fa1 - 9

switchport access vlan 1

interface vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

access-list 1 permit 192.168.1.0 0.0.0.255

ip nat inside source list 1 interface fa0 overload

The above configuration configures your WAN to get an IP from your DSL/cable modem. Your LAN is configured for DHCP in the 192.168.1.0 range, and the router will be performing NAT in between the LAN and WAN.

Will

nat.watkins Mon, 09/17/2007 - 04:53

Thanks Will for your response. Is there a way to do it without natting inside to outside.

We have 10.2.114.x on outside, we have 10.152.0.0/16 on inside. With 10.152.0.1 assigned to fa0 . What I would like to do is plug a pc into switch and give it a 10.152.0.2,3,4,5,6 and allow it to route to 10.2.114.x

Make sense?

Thank you again

nat.watkins Wed, 09/19/2007 - 07:50

All

Is is possible to route from FA0 and switch ports to FA1. Example, FA1 has 10.2.114.18

and Fa0 has 10.152.0.1 on the Fa0 side I have a whole class B some of which I would like to assign to Pcs and plu into the switch ports.

Sw port 1 would have 10.152.0.2 Sw port 2 would have 10.152.0.3 and so on. I would like for these to route (not nat) to fa1. Is this possible?

Thanks

Actions

This Discussion