OSPF Troubleshooting

Unanswered Question
Sep 15th, 2007

Dear Expert,

I am doing a migration between the 3660 routers and 7609 router.

I have an existing ppp multilink network, Main Headquarter and around 22 Remote Sites using 3660 routers and an ospf routing protocol.

When we are trying to migrate the main headquarter from 3660 routers to the new 7609 router, Its seems okay, it advertised the multilink address, serial interface address etc. but one thing I noticed is the fastethernet IP address is not advertised which is very important to our data servers (e-mail, servers, active directory etc.)

Any idea how can I fix this issue, since the fastethernet IP address in the router is not advertising, I put it back again to the old 3660 routers to access to their data.

Your input is highly appreciated.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
paul.matthews Sat, 09/15/2007 - 22:48

What would help would be a copy of the config you are using so that we can see what is hapenning, in terms of troubleshooting, the first thing to do is check the remote router for an LSA for the route - if both routers are in the same area, all networks should have an LSA present in the LSA database. If it is not there you need to look at why it is not there, If it is there you need to look at why it may not be going to the routing table.

If the LSA is not there, send us the output of "sh ip ospf int" you then need to carefully check the network statements to make sure the interface is covered by a network statement. In reality as that is probably the most likely cause I would look at that first.

Richard Burts Sun, 09/16/2007 - 12:46


In addition to the configuration it would be helpful if you would post the output of show ip interface brief and of show ip ospf interface.

It would also be helpful to know when you were attempting to use the new router if the router was able to ping (or any other kind of access) to the servers on the subnet of the FastEthernet interface.



JUNKSA_2 Mon, 09/17/2007 - 02:20

Dear Paul and Rick,

Guys, thank you. anyway I will attached the required config you requested.

To brief you, The rest of the remote sites was still connected to the existing 3660 router in the main headquarter, the 3660 router will be replaced with 7609 router as part of the migration.

I cannot disconnect the remote routers unless the 7609 router will work properly. Before I tried to disconnect all the interface from the old router and moved it to the new router (7609) but I failed, as I have said before I can ping all the interface, multilink, serial interface, tunneling but not the fastethernet IP which is very important for the administrator that managing the servers.

To avoid this issue, I connect only one remote site named Jizan (3660 router) was connected via E1 (G.703) to Riyadh (7609 router) which is also located in the main headquarter to start as the pilot testing site.

I will attached the config and other results that you requested.

I hope it will help and thank you for your time.

Note: Guys can you give me your e-mail add, I cannot send the information you requested.



Kevin Dorrell Mon, 09/17/2007 - 07:50

Is anyone else getting a server error when they try and open an attchment, or is it just me?

paul.matthews Mon, 09/17/2007 - 23:47

Right, looking at these I note:


interface FastEthernet0/0

ip address

duplex auto

speed auto

router ospf 2


network area 0

network area 0

Which is a fas ethernet into area 0 of OSPF process 2.

On the 7609;

interface FastEthernet1/2


switchport access vlan 10

no ip address


interface FastEthernet1/3

no ip address


interface FastEthernet1/4

no ip address


interface FastEthernet1/5

no ip address


interface FastEthernet2/2

no ip address


interface FastEthernet2/3

no ip address


interface FastEthernet2/4

no ip address


interface FastEthernet2/5

no ip address

interface Vlan10

description Riyadh

no ip address


No fast ethernet interfaces have an IP address. On is in VLAN10, but that does not have an IP address, and is shut down. The IP network that appears on the fast ethernet in the 3660 is not in this router at all.

Based on that, it appears the fast ethernet is not configured for IP, which means it cannot be advertised, and the same network is not included in either OSPF process.


glen.grant Mon, 09/17/2007 - 03:19

Makes sure your network statements covers the fast ether subnet otherwise it will not be advertised .

Richard Burts Mon, 09/17/2007 - 08:19


Thank you for the additional information that you posted. I believe that it demonstrates that the FastEthernet is being advertised. But advertised only on one interface.

I notice in the config that you have configured 2 OSPF processes. I am not clear why you did this but I believe that it is the cause of the apparent problem here. Note that each OSPF process maintains its own version of the Link State Data Base.

I asked for the output of show ip interface brief and of show ip ospf interface as easy ways to find whether the interface was up/up (and it is), if it has a valid IP address (and it does) and if it is included within an OSPF network statement (it is because it is included in the output as an OSPF interface).

Here is part of the output and it includes a significant clue:

FastEthernet0/0 is up, line protocol is up

Internet Address, Area 0

Process ID 2

note the process ID is 2 where most of the other interfaces have process ID of 1.

There are only 2 interfaces configured in OSPF process 2 - FastEthernet0/0 and Tunnel 0. So the FastEthernet is being advertised over the tunnel 0. But it is not advertised out any other interface because OSPF will only advertise routes that are from the Link State Data Base of its own process. If you check the router at the other end of Tunnel 0 I am sure that you will find that is being advertised over the tunnel. But it is not advertised over any other interface.



JUNKSA_2 Mon, 09/17/2007 - 08:38

Hi Rick,

I really appreciate your comments and observation.

Regarding the 2 OSPF process, When I take over the project the configuration is already there and the network is running well in that configuration up to now. I think I will send you the existing config from the other remote router that is connected to the main head quarter for comparison.

Thank you.


JUNKSA_2 Tue, 09/18/2007 - 06:26

Hi Rick,

I checked the other remote site that is connected to the main site.

I think the reason why he configured two (2) OSPF processes in his recent configuration, in the main site we have two (2) 3660 routers, 9 remote sites are directly connected to the first router and the other 7 remote sites are connected to the other router for load balancing and there is a tunneling between the two (2) routers.

Now, since we have only one (1) 7609 router in the main site, I think, no need to configure two (2) OSPF process in this scenario.

This morning, I removed the other ospf process on both ends (Jizan and Riyadh Site) and I add the statement for the fastethernet and the tunneling 0 in OSPF 1 on both ends and its work, when I checked the IP route, the fastethernet and tunneling 0 are advertised. I can ping the fastethernet IP address.

What is your opinion?


Richard Burts Tue, 09/18/2007 - 07:22


If I understand correctly that there were two 3660 routers at the main site and the tunnel connected those two routers and if the two 3660 were consolidated into 7609 then where does the tunnel go now? I wonder if the tunnel has any purpose now?

I am still not entirely clear why the tunnel and two OSPF processes was used instead of a direct connection and a single OSPF process. But if the tunnel did connect those two routers and they are now consolidated into one router then I see no reason for the tunnel or for two OSPF processes. You know the local environment better than we do and might realize some aspect of this that we have not yet considered.



JUNKSA_2 Tue, 09/18/2007 - 13:16

Hi Rick,

Guys, Sorry for the confusion, Okay, here is the scenario; two (2) 3660 routers are located in the main site and a tunnel connected to those two routers.

7609 router is not connected yet to the rest of the remote sites, I assigned one remote site and connected to the new 7609 router for testing.

I will attached the network layout so you will get a whole picture.




This Discussion