PPPoE 876 - Problem

Unanswered Question
Sep 16th, 2007
User Badges:

Hi all,


I have problem with configuring 876 to work as pppoe client. Is there anyone who have configuration example which work?


After all I configure all parameter for whom in consider as important, and try to debug I?m receiving this error ?padi timer expire?. I know to this error pointing on my IPS, but I?m wondering is there any way that I didn?t configure something properly ?


Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Paolo Bevilacqua Sun, 09/16/2007 - 04:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please send your config and "show atm pvc x/y" whee x/y are the VPI/VCI values you have configured.

bojan.vujic Sun, 09/16/2007 - 22:42
User Badges:

This is configuration example of 876. I didn?t configure NAT yet. Also I?m not using ATM, I?m using regular Ethernet.

Building configuration...


Current configuration : 1357 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxxxx

!

boot-start-marker

boot-end-marker

!

enable password 7 xxxxx

!

no aaa new-model

!

resource policy

!

ip cef

!

!

!

!

vpdn enable

!

!

!

!

!

!

!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

!

interface FastEthernet3

switchport access vlan 2

pppoe enable group global

pppoe-client dial-pool-number 1 dial-on-demand

!

interface Vlan1

ip address 10.0.0.1 255.255.255.0

!

interface Vlan2

ip address 169.x.x.2 255.255.0.0

!

interface Dialer0

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication ms-chap callin

ppp chap hostname xxxxxxx

ppp chap password 7 xxxxxxx

ppp ipcp dns request

ppp ipcp address accept

!

ip route 0.0.0.0 0.0.0.0 Dialer0

!

!

no ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password xxx

login

!

scheduler max-task-time 5000

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

Paolo Bevilacqua Mon, 09/17/2007 - 03:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yoy may be in murky waters, because cisco may not have thested PPPoE on the ports that normally are used for access.


padi timeout mean there is no answerd to request to initiate PPPoE.


Can't you connectvia ATM ?

bojan.vujic Mon, 09/17/2007 - 03:09
User Badges:

Unfortunately I can?t. This is wireless ISP, end all what I have is Ethernet. Strange thinks is that I know that this kind of router already work fine on this kind of network on this WISP, and even I have configuration of that one, I can make this one to work.. I think problem is somewhere in VPDN configuration?.


I try all what I know, and I don?t know what else to try?


Paolo Bevilacqua Mon, 09/17/2007 - 03:54
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

The thing is that you would need an 851 or 871 for this application. Even after you get the PPPoE working, you would end with NAT inside and outside interfaces on the same physical ports, and the router may not like this at all.


Anyway. Please configure the pppoe things under vlan1, not physical interface. Note vpdn is not needed for pppoe cliente, is it vestigial from old documentation.


Hope this helps, please rate post if it does!


bojan.vujic Mon, 09/17/2007 - 04:02
User Badges:

Problem is solved,


I make changes in configuration like I remove pppoe enable group global and

pppoe-client dial-pool-number 1 from physical L2 fast Ethernet to L3 interface Vlan 2. After that all start to work fine.


So pppoe attributes must be on L3 interface?.


Paolo Bevilacqua Mon, 09/17/2007 - 04:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes. Let us know if nat is working, it shoudl as you are conficuring different vlan for access and a PCs'.


As a recognition to those those providing answers, please rate useful posts using the scrollbox below

Paolo Bevilacqua Mon, 09/17/2007 - 04:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Good. Friendly said, please try to use better fairness in rating next time.

Actions

This Discussion