Link Trunk / Non Trunk Mismatch

Answered Question
Sep 16th, 2007
User Badges:

Hi,


I am using Cisco Works LMS 2.6. If I do a check for discrepancies, I get a Link Trunk / Non Trunk Mismatch, between our 6500 and 4500. These are linked together with fibre and etherchannel.


I cannot seem to find why it's complaining as the trunking of VLANS works OK, and I'm sure the config is OK. Please could you check it below to see if it's correct?


6500:


set port channel 1/12-13 157

set vlan 400 1/1-14,1/16

clear trunk 1/12 1

set trunk 1/12 on dot1q 2-4094

clear trunk 1/13 1

set trunk 1/13 on dot1q 2-4094


set port channel 1/12-13 mode desirable silent


4500:


interface Port-channel2

description Link to Core 1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 400

switchport trunk allowed vlan 2-4094

switchport mode trunk


interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 400

switchport trunk allowed vlan 2-4094

switchport mode trunk

channel-group 2 mode desirable


interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 400

switchport trunk allowed vlan 2-4094

switchport mode trunk

channel-group 2 mode desirable


I really hope someone can explain this to me. Is it the config, or is Cisco Works sometimes wrong?


Kind regards


James

Correct Answer by Joe Clarke about 9 years 10 months ago

Campus Manager doesn't look at the config to compute trunking status. It does it all via SNMP. For both switches, it will use the vlanTrunkPortDynamicState object from the CISCO-VTP-MIB to determine whether or not the port is trunking. There may be an SNMP issue in one of the versions of code where the trunk status is not being properly reflected via SNMP.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Sun, 09/16/2007 - 08:35
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Campus Manager doesn't look at the config to compute trunking status. It does it all via SNMP. For both switches, it will use the vlanTrunkPortDynamicState object from the CISCO-VTP-MIB to determine whether or not the port is trunking. There may be an SNMP issue in one of the versions of code where the trunk status is not being properly reflected via SNMP.

james.mathieson Sun, 09/16/2007 - 08:43
User Badges:

I have probably been chasing a fault that isn't really there then.


Many thanks for your prompt reply.


James


Actions

This Discussion