Etherchannel error

Unanswered Question
Sep 16th, 2007

Hello. I`m create etherchannel between two catalyst 4503 and 3750. Then i plug cable log on 4503 is ok, but log on the 3750 not ok.

013402: Sep 14 17:14:44: %EC-5-CANNOT_BUNDLE2: Gi1/0/18 is not

compatible with Po4 and will be suspended (trunk mode of Gi1/0/18 is

dynamic, Po4 is trunk)

013405: Sep 14 17:14:46: %LINK-3-UPDOWN: Interface

GigabitEthernet1/0/18, changed state to up

013427: Sep 14 17:15:07: %EC-5-CANNOT_BUNDLE2: Gi1/0/19 is not

compatible with Po4 and will be suspended (trunk mode of Gi1/0/19 is

dynamic, Po4 is trunk)

013438: Sep 14 17:15:09: %LINK-3-UPDOWN: Interface

GigabitEthernet1/0/19, changed state to up

Configuration on the port:

interface GigabitEthernet1/0/18

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

channel-group 4 mode desirable non-silent

spanning-tree link-type point-to-point

interface GigabitEthernet1/0/19

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

channel-group 4 mode desirable non-silent

spanning-tree link-type point-to-point

interface Port-channel4

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

end

Where is my mistake?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jlhainy Sun, 09/16/2007 - 06:36

It looks like you are using PAgP to negotiate your etherchannel in this config. That is shown by the fact that you are using the mode desirable command. Is the other switch also using the same command? In order for an etherchannel to be successful, they both need to use the same protocol or none at all.

CSCO11227244 Sun, 09/16/2007 - 06:55

This config 4503:

interface GigabitEthernet3/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport trunk pruning vlan none

switchport mode trunk

switchport nonegotiate

channel-group 4 mode desirable non-silent

spanning-tree link-type point-to-point

end

interface GigabitEthernet3/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport trunk pruning vlan none

switchport mode trunk

switchport nonegotiate

channel-group 4 mode desirable non-silent

spanning-tree link-type point-to-point

end

interface Port-channel4

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

end

glen.grant Sun, 09/16/2007 - 07:49

On each port channel try using switchport trunk mode dynamic desirable and also pull the switchport nonegotiate command on both sides . To me the current setup looks like it should work . What you might want to try is to default both those interfaces , makes sure all your commands are under the port channel interface and then just apply the channel command "channel-group 4 mode desirable non-silent" . Also verify those ports are switchports and not routed ports . As part of your commands make sure the first command is "switchport" .

CSCO11227244 Sun, 09/16/2007 - 11:02

Look this:

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml

"Issue the channel-group command first, before you enter any other commands on these

interfaces. Any commands that you issue on these interfaces after you issue the

channel-group command are added to the port channel interface automatically.

If you configure the port with all the commands and you issue the channel-group

command last, the port channel interface is created but does not have any

configurations. You must then add the other commands to the port channel interface

manually."

Maybe this my mistake?

Then i configure my interfaces, i first issue

interface range gigabitethernet 1/0/18 - 19

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

then after

interface range gigabitethernet 1/0/18 - 19

channel-group 4 mode desirable non-silent

and therefore log say`s "trunk mode of Gi1/0/18 is

dynamic, Po4 is trunk"

because command "switchport mode trunk" do not apply on interface 1/0/18 - 19

Tomorrow i check it.

glen.grant Sun, 09/16/2007 - 12:17

I think you configure all your parameters on the port-channel interface then apply it to your interfaces via the channel-group command.

After you configure an EtherChannel, the configuration that you apply to the port-channel interface affects the EtherChannel; the configuration that you apply to the physical interfaces affects only the interface where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply configuration commands to the port-channel interface (such commands can be STP commands or commands to configure a Layer 2 EtherChannel as a trunk).

Actions

This Discussion