2003 & Inter-vlan Routing

Unanswered Question
Sep 16th, 2007

Hi,

May or may not be a simple question - I'm helping someone setup a network with a 3750 and a NME-16ES-1G-P card. It took me a while to get my head around the fact the card was the router and not the actual router... anyway...

We have put Windows 2003 servers onto one vlan and clients onto another and bascially they arent seeing the servers ??

Now I have added ip helper-address into the config and the default gateways etc are correct. Does it need ip multicast-routing for this to work ?? WHat am I missing ?

Thanks

Ed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Sun, 09/16/2007 - 09:22

Are you sure it is a 3750 ? That is a layer 3 switch already , I'm guessing it is a 3745 or soemthing like that ? Maybe you can post a show ip int brief and a show vlan command or the whole config if possible with the addresses partially hidden , this gives us a better idea of what we are looking at . My guess is that you maybe did not create the layer 2 vlans for the subnets which is why they won't talk . No multicasting should have nothing to do with it .

edw Sun, 09/16/2007 - 10:48

Hi,

Sorry its a Cisco 2821 not a 3750 ;). On the NME-16ES-1G-P I ave configure vlan 2 & 3 with ip addresses.

version 12.2

!

!

hostname Test

!

!

switch 1 provision NME-16ES-1G-P

ip subnet-zero

ip routing

!

!

vlan internal allocation policy ascending

!

interface FastEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2-3,99

switchport mode trunk

!

!

interface Vlan1

no ip address

!

interface Vlan2

ip address x.x.200.1 255.255.255.0

!

interface Vlan3

ip address x.x.300.1 255.255.255.0

!

interface Vlan99

ip address x.x.201.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x

Thanks

Ed

Richard Burts Sun, 09/16/2007 - 12:34

Ed

The configuration of VLANs 2, 3, and 99 look ok. I would expect routing between these VLANs to work.

I do not see anything that assigns ports to VLANs. It would be nice to see those assignments and to rule out the possibility that some of the ports are defaulting to VLAN1 which is not routed.

I have not configured this kind of switch card on a router before so I can not speak from experience. But I wonder if you are explicitly configuring interface FastEthernet1/0/1 as a trunk, if the VLANs should be configured as subinterfaces on the interface.

As a simple test, can the router ping any of the devices (clients or server)? This would help demonstrate whether there is VLAN connectivity from the router perspective.

HTH

Rick

edw Sun, 09/16/2007 - 13:39

Hi All,

Thanks for the reply. The vlans are routing as I can ping between them from machine inside. IE if I have a machine on vlan 2 and a machine on vlan 3 they can ping each other. Machines on each vlan can get internet access too.

The problem is that the machine on vlan 3 won't logon to the servers in vlan 2. I can ping them but they're seeing them in nwtork neighbourhood and they won't do lookups either.

Thanks

Ed

Richard Burts Sun, 09/16/2007 - 16:32

Ed

Your original post indicated that you had configured ip helper-address. But I am not seeing any helper-address in the config that you posted. From the most recent description of the symptoms I would guess that helper-address needs to be configured under the VLAN 3 interface pointing to the address of the server(s) in VLAN 2.

HTH

Rick

edw Mon, 09/17/2007 - 02:05

Sorry ;) I have put the ip helper-address in - but not under the vlan interface just under the main router config. I didn't add it as that was the pre config before - sorry...

Thanks

Ed

Actions

This Discussion