Default gateway not routing properly

Answered Question
Sep 17th, 2007
User Badges:

Hi


I have 2 routers on a point to point network. When the user from the LAN try to trace to the core router (CR1) the trace stops on the router connected to his LAN. He cannot get past the serial interface on his router. However when I connect to his router I can ping the core router.


Attached is the running config of his router on his LAN.


Thanks

wvw



Attachment: 
Correct Answer by lgijssel about 9 years 8 months ago

From your post I cannot verify if this is the only router at the remote site. Does the trace indeed go to 192.168.2.2?

If not, the users default gw is probably misconfigured.

For the rest, is this a new config or has this already been working?

Normally you should also add the 192.168.2 network to eigrp also using: "network 192.168.2.0".

Without this, the other router (CR1) will not have a route for network 192.168.2.0.


regards,

Leo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
lgijssel Mon, 09/17/2007 - 01:46
User Badges:
  • Red, 2250 points or more

From your post I cannot verify if this is the only router at the remote site. Does the trace indeed go to 192.168.2.2?

If not, the users default gw is probably misconfigured.

For the rest, is this a new config or has this already been working?

Normally you should also add the 192.168.2 network to eigrp also using: "network 192.168.2.0".

Without this, the other router (CR1) will not have a route for network 192.168.2.0.


regards,

Leo

Jon Marshall Mon, 09/17/2007 - 01:51
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


I think Leo has hit the nail on the head. If you ping from the router it will use it's serial IP address and so the core router will know how to route back to it.


On your core router if you do a show ip route - is there a route back to 192.168.2.x.


If not either do as Leo suggested and add it under your EIGRP config "network 192.168.2.0" or add a static route at core site - probably best to go with EIGRP tho.


Jon

paul.matthews Mon, 09/17/2007 - 01:51
User Badges:
  • Silver, 250 points or more

I am with Leo - I suspect the problem is that the core router does not have a route back. Turn off auto summary on EIGRP and add the lan interface using a network statement.


I say to turn off auto summary as I suspect you will be using a number of these subnets. Allowing autosummary would mean all routers with one of these subnets would all advertise the same into eigrp!

smothuku Mon, 09/17/2007 - 01:52
User Badges:
  • Silver, 250 points or more

Hi ,


add reditribute static under eigrp.


Thanks,

satish

paul.matthews Mon, 09/17/2007 - 01:55
User Badges:
  • Silver, 250 points or more

If redistributing it would need to be connected not static. Better to use a network statement though as that keeps it an an eigrp internal route.

Actions

This Discussion