cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
419
Views
0
Helpful
5
Replies

ISDN Dialer profile authenticates then disconnects

skelk
Level 1
Level 1

I have a Cisco 3745 as follows:

2 FastEthernet interfaces

31 Serial interfaces

1 ISDN Basic Rate interface

60 terminal lines

2 Channelized E1/PRI ports

I have it configured for dial in with radius authentication for PSTN users. This works fine and all ASYNC users connect fine. However, when an ISDN user connects they authenticate fine, but the connection then drops. I have debugged ppp authentication and it seems fine. I can't find any errors.

I am sure I am missing some config somewhere. Any help you guys can give is appreciated :)

Cisco 3745 config (chopped)

!

hostname router1

!

aaa new-model

!

aaa group server radius groupname

server x.x.x.x auth-port 1812 acct-port 1813

server x.x.x.x auth-port 1812 acct-port 1813

!

aaa authentication ppp profilename group groupname

aaa authorization network default group groupname

aaa accounting delay-start

aaa accounting update newinfo periodic 5

aaa accounting exec default start-stop group groupname

aaa accounting network default start-stop group groupname

!

aaa session-id common

modem country mica e1-default

no ip source-route

ip cef

!

!

no ip domain lookup

multilink virtual-template 1

isdn switch-type primary-net5

isdn tei-negotiation first-call

!

!

controller E1 3/0

pri-group timeslots 1-31

!

!

interface FastEthernet0/0

ip address x.x.x.x x.x.x.x

!

interface Serial3/0:15

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer pool-member 1

no snmp trap link-status

isdn switch-type primary-net5

isdn incoming-voice modem

fair-queue 64 256 0

no cdp enable

ppp authentication chap profilename

ppp multilink

!

interface Virtual-Template1

ip unnumbered FastEthernet0/0

no peer default ip address

ppp authentication chap profilename

ppp multilink

!

interface Dialer0

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer pool 1

no peer default ip address

no cdp enable

ppp authentication chap profilename

ppp ipcp dns x.x.x.x x.x.x.x

ppp multilink

!

interface Group-Async1

ip unnumbered FastEthernet0/0

encapsulation ppp

async mode interactive

no peer default ip address

no fair-queue

ppp authentication chap profilename

ppp ipcp dns x.x.x.x x.x.x.x

ppp multilink

group-range 33 62

!

!

radius-server host x.x.x.x auth-port 1812 acct-port 1813

radius-server host x.x.x.x auth-port 1812 acct-port 1813

radius-server retransmit 2

radius-server key xxxxxx

Remote router:

interface BRI0/1

ip address xxxx

encapsulation ppp

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

!

interface Dialer1

bandwidth 64

ip address negotiated

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer string xxxxxxx

dialer-group 1

compress predictor

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxx

ppp chap password xxxx

ppp multilink

Debug outputs attached.

5 Replies 5

lgijssel
Level 9
Level 9

Looks like it's failing on the link compression:

Sep 17 14:29:47: BR0/1:1 LCP: I PROTREJ [Open] id 89 len 12 protocol CCP (0x80FD013500060102)

This parameter is only configured on the remote side: compress predictor

You can either configure it on both sides or remove it from both. At least you can see if it makes any difference when you play with this setting.

regards,

Leo

Hi Leo - Thank you for your reply. I have removed this setting now and it seems to be doing the same thing... authenticates then disconnects. :(

Looking at the history on the forum - a few people have reported this issue - but I can't see any fix.

The other thing I noticed was:

Sep 17 11:43:50: BR0/1:1 CHAP: Username ROUTER1 not found

While the interface is a BRI instead of PRI I think this is probably on the other end?

Can you try to add the following line to the remote router:

username router1 password

regards,

Leo

Hi Leo,

giving this a whirl but now radius files so trying to figure out what is up there... will post results.

Radius was failing because of the password used. This is now correct and authenticates again, but disconnects straight after :(

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: