Etherchannel problem

Unanswered Question

I have a 3750 stack in one of my MDFs, this stack connects to 4 additional 3750 stacks via redundant fiber connections (2 connections to each IDF). I have bundled each of the fiber connections, but I just noticed that when I do a "show etherchannel detail" on the core stack there is only 1 port active in each etherchannel. When I remove the channel-group configuration at the interface level and then put it back, one port in the bundle immediatly leaves the group. The interface configuration is as follows:

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

The "show etherchannel 1 detail" gives the following:

Group state = L2

Ports: 2 Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol: -

Minimum Links: 0

Ports in the group:

-------------------

Port: Gi1/0/1

------------

Port state = Up Mstr In-Bndl

Channel group = 1 Mode = On Gcchange = -

Port-channel = Po1 GC = - Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:00h:07m:29s

Port-channels in the group:

---------------------------

Port-channel: Po1

------------

Age of the Port-channel = 10d:18h:27m:21s

Logical slot/port = 10/1 Number of ports = 2

GC = 0x00000000 HotStandBy port = null

Port state = Port-channel Ag-Inuse

Protocol = -

Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits

------+------+------+------------------+-----------

0 00 Gi1/0/1 On 0

Time since last port bundled: 0d:00h:07m:29s Gi2/0/1

Time since last port Un-bundled: 0d:00h:09m:53s Gi1/0/1

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Kevin Dorrell Mon, 09/17/2007 - 08:09

Is it possible that the problem lies at the other end of this channel link? Are the two corresponding ports on the other end of the link correctly configured and bundled? This is the sort of behavior I might expect if the two ports making the bundle at the other end are mismatched and therefore unable to form a bundle.

Maybe they are crossed between different distribution switches. At the core switch, if you show cdp neighbors, are these two ports connected where you think they are connected?

Kevin Dorrell

Luxembourg

glen.grant Wed, 09/19/2007 - 16:10

No he is forcing the etherchannel on which is ok on crosstack etherchannel. that is the problem when you force on a etherchannel it can look like it is working like on one side like you are seeing , you might want to try and use lacp instead and see what happens.

alexkotlov Thu, 09/20/2007 - 00:25

It is not helping! =). I tested Cross-Stack Etherchannel in both mode. Result was the same. I changed even Stack Master (from switch 1 to 2) and after election the bundled port Gi1/0/1 is displayed in the Etherchannel only through 'remote command 1 sh etherchannel 1 port', but all is working. =)

It is IOS Release 12.2(40)SE bug. I am fully confident.

l.mourits Fri, 09/21/2007 - 03:55

Make sure you have both ports on both switches configured to "on" mode if you want to run etherchannel without using LCAP for cross-stack etherchannels.

HTH,

Leo

Actions

This Discussion