Trusting DSCP in a Cat4500 on routed ports.

Unanswered Question
Sep 17th, 2007

We have a 4503 with Sup II+ running IOS 12.2(37)SG. Our Avaya PBX medpros and clans are connected to the WS-X4548-GB-RJ45 blade. Two ports of that same blade are the uplinks to two 6506 distribution switches.

The uplink ports are L3, and the ports connected to the medpros and clans are of course L2.

Here is an example of the QOS commands and an uplink port config and a medpro connected port config:

policy-map autoqos-voip-policy

class class-default

dbl

qos

qos dbl

qos map dscp 24 25 26 27 28 29 30 31 to tx-queue 4

qos map dscp 32 33 34 35 36 37 38 39 to tx-queue 4

qos map cos 5 to dscp 46

interface GigabitEthernet1/1

description GHQ-RS6506A G3/2 E215

no switchport

ip address xxx.xxx.xxx.xxx 255.255.255.252

interface GigabitEthernet2/37

description Medpro #1

switchport access vlan 910

switchport mode access

speed 100

duplex full

qos trust dscp

auto qos voip trust

tx-queue 3

priority high

no cdp enable

spanning-tree portfast

service-policy output autoqos-voip-policy

interface Vlan910

ip address xxx.xxx.18.1 255.255.255.128

The Avaya PBX marks the voice packets with DSCP=46 and the control packets with DSCP=24.

To insure that the uplinks don't zero out the markings, to trust them, do I need to add a voip trust statement to the G1/1 config even though it is an L3 interface?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Fri, 09/21/2007 - 13:52

If you are concerned with setting up a port on this 4507R tosupport a Cisco IP phone, then I recommend using the 'auto qos voip cisco-phone' interface command,after enabling 'qos' globally on the switch. This will do two things: one it will set up the port to

'trust cos' and it will set up the priority for the 3rd tx-queue on the interface. This will prioritize packets being transmitted to the phone. In addition, if you have configured a vlan other than vlan 1 to be the voice vlan you should configure 'switchport voice vlan ' under the inteface.

Actions

This Discussion