internet access using Cisco 1841 router

Unanswered Question
Sep 18th, 2007
User Badges:

hi can any one please advice me how to configure a cisco 1841 router with ADSL port , i dont find any articles related to it,I have ADSL internet , can anyone please send me articles or advice regarding this, thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 09/18/2007 - 01:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What encapsulation (PPPoA, PPPoE, rfc1483) is you ISP using ?

Whit this information one can point to a link with configuration examples.

shajil Tue, 09/18/2007 - 12:16
User Badges:

thanks a lot for your reply


the encapsulation used is PPPoA,

any configuration examples also vl b of great help

paolo bevilacqua Tue, 09/18/2007 - 16:19
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Juste replace VPI/VCI and username/password as needed. Please rate post if useful!


ip dhcp pool lan

network 10.10.10.0 255.255.255.0

dns-server 10.10.10.1

default-router 10.10.10.1

!

interface ATM0

no ip address

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode itu-dmt

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip pim sparse-dense-mode

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

no ip unreachables

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username aliceadsl password 0 aliceadsl

ppp ipcp dns request

ppp ipcp route default

!

ip dns server

ip nat inside source list Nat-Control interface Dialer0 overload


ip access-list extended Nat-Control

permit ip 10.10.10.0 0.0.0.255 any



shajil Tue, 09/18/2007 - 21:49
User Badges:

thanks a lot for the quick reply,will go through the configuration and try it out,its great pleasure getting advice from cisco experts..

shajil Wed, 09/19/2007 - 00:04
User Badges:

m went through the configuration,i jst cant apply the dialer pool-member 1 command under atm interface, SHALL I have to use transmit-interface dialer 1 instead?also is it not required to enable pppoe under atm,if so ,how shall i?please advice me


am sorry,am a little bit confused regarding the encapsulation used ,if its PPPoA or PPPoE,incase if its PPPoA ,i think its fine,can u explain the command "encapsulation aal5mux ppp dialer" under ATM interface


also am not able to create vlan interface using interface vlan1,shall i have to use Bridged virtual interface instead??

Actions

This Discussion