Port Channel Settings

Unanswered Question
Sep 18th, 2007

Hi,

Trying to setup a port channel between to Catalyst 6506's, the commands are accepted but the channeling doesn't work.

The commands I used are :

set trunk 1/1,1/2 on dot1q

set port channel 1/1,1/2 mode on

I have set these commands on both switches.

One Cat is running 8.4.5 and the other 8.5.5.

What am I doing wrong ?

Regards

Scott.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sdawson35 Tue, 09/18/2007 - 04:53

Hi Mahmood,

Does the admin group number have to match on both Cats ?

Scott.

Jon Marshall Tue, 09/18/2007 - 05:00

Scott

No it is only locally significant. Could you send output of

"sh channel info"

"sh trunk"

Jon

sdawson35 Tue, 09/18/2007 - 05:10

Hi Jon,

sh channel info

No ports channelling

sh trunk

* - indicates vtp domain mismatch

# - indicates dot1q-all-tagged enabled on the port

$ - indicates non-default dot1q-ethertype value

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

1/1 on dot1q trunking 1

1/2 on dot1q trunking 1

2/1 on dot1q trunking 1

2/3 on dot1q trunking 1

2/5 on dot1q trunking 1

2/7 on dot1q trunking 1

2/9 on dot1q trunking 1

2/16 on dot1q trunking 1

3/2 on dot1q trunking 1

3/3 on dot1q trunking 1

3/4 on dot1q trunking 1

3/5 on dot1q trunking 1

15/1 nonegotiate isl trunking 1

Kevin Dorrell Tue, 09/18/2007 - 05:13

Check the configurations on 1/1 and 1/2 match exactly before you try and put them into a channel. Mismatched VLAN lists, for example, can stop them forming a channel.

The other end of the channel must also be configured "on". The "on" option stops the negotiation, so "on" will not work opposite "desirable" or "auto".

Kevin Dorrell

Luxembourg

sdawson35 Tue, 09/18/2007 - 05:21

Hi Kevin,

Have found one differaence between the 2 ports on one of the cats !!.

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

1/1 1-3,5,8-9,16-22,26,32,64-66,101,104,109,116-122,126-128,204,802,901

1/2 1-3,5,8-9,16-22,26,32,64-66,101,104,109,116-122,126-128,204,802,901

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

1/1 1-3,5,8-9,16-22,26,32,64-66,101,104,109,116-122,126-128,204,802,901

1/2

Kevin Dorrell Tue, 09/18/2007 - 05:32

I don't think that is the source of the problem. The allowed VLAN list are the same unless I missed something. Just that one of the links has been put in standby, which is what you would expect from Spanning Tree when you have two parallel links.

Oh, you could check that the ports actually support channel? For example, if I remember right, the ports on a 5500 sup card do not support channel. Try show port capabilities 1/1

Kevin Dorrell

Luxembourg

sdawson35 Tue, 09/18/2007 - 05:38

These are Cat6500 series (6506) with SupII & MSFCII.

Looks like it should work ?.

sh port capabilities 1/1

Model WS-X6K-SUP2-2GE

Port 1/1

Type 1000BaseSX

Auto MDIX no

AuxiliaryVlan no

Broadcast suppression percentage(0-100)

Channel yes

COPS port group 1/1-2

CoS rewrite yes

Dot1q-all-tagged yes

Dot1x yes

Duplex full

Fast start yes

Flow control receive-(off,on,desired),send-(off,on,desired)

Inline power no

Jumbo frames yes

Link debounce timer yes

Link debounce timer delay yes

Membership static,dynamic

Port ASIC group 1/1-2

Port VLAN Mapping Group: 1/1-2 Maximum Allowed Mappings: 32

Port VLAN Mapping Supported Trunk Type: dot1q

QOS scheduling rx-(1p1q4t),tx-(1p2q2t)

Security yes

SPAN source,destination

Speed 1000

Sync restart delay yes

ToS rewrite DSCP

Trunk encap type 802.1Q,ISL

glen.grant Tue, 09/18/2007 - 05:41

USe the following. The ports and speed settings must be exactly the same on both sides

set trunk 1/1-2 on dot1q

set port channel 1/1-2 mode desirable non-silent

Actions

This Discussion