LMS3.0 100% config fetch/archive failure

Unanswered Question
Sep 18th, 2007

Hi,

I am recieving an error message for any device that I try to collect or archive a config on. I have tried to collect a single config by itself without any success.

The error is telling me to increase my fetch settings which do not work or change anything.

I did turn on the debug on and listed below is a sample of the results. I did not inlcude all the lines because they were all the same.

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.util.DCRWrapperAPIs,getResultFromQuery,2838,Query: select DCR_ID from DM_Dev_State where NetworkElementID = '83'

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.util.DCRWrapperAPIs,getDCRId,1082,dev id: 83 dcr id : 83

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.util.DCRWrapperAPIs,getAPIExtraInfo,2753,InheritableThreadLocal value not set: Setting it

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.util.DCRWrapperAPIs,initAPIXtraInfo,2514, Source context set to: vhamwvnms3/10.40.106.57__DCRWrapperAPIs__4.0

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.util.DCRWrapperAPIs,initAPIXtraInfo,2537, Security context set to: admin

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.util.DCRWrapperAPIs,getDisplayNameForDev,849,dev id: 83Disp name : mwv5001a106sw01

[ Fri Sep 07 13:13:52 EDT 2007 ],DEBUG,[Thread-3],com.cisco.nm.rmeng.dcma.configmanager.CfgThreadManager,triggerConfigFetch,40,Config fetch request received

[ Fri Sep 07 13:13:57 EDT 2007 ],DEBUG,[Thread-111],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,getStatusOfRequest,913,Total devices due for reqId = 1189185232687 is 1

[ Fri Sep 07 14:10:03 EDT 2007 ],DEBUG,[Thread-5],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,getStatusOfRequest,913,Total devices due for reqId = 1189185232687 is 1

Thanks for the help.

Jason

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Tue, 09/18/2007 - 05:10

This debug output doesn't really show much. What is the actual error you are receiving when trying to archive a devices config? If you set it up for one device, what error does it show in the job results?

vhamwvbarnaj Tue, 09/18/2007 - 05:17

Thanks for the quick response, the error is posted below. Could there be a rights issue on the server and writing to files? A little history on the problem and when it started.

We had alot of data in ciscoworks that was old, and out dated due to the server not being managed. I ran the following commands to restore the databases to original form therefore allowing the system to re-discover all the devices.

"net stop crmdmgtd

1. NMSROOT\bin\perl dbRestoreOrig.pl dsn=rmeng dmprefix=RME

2. NMSROOT\bin\perl dbRestoreOrig.pl dsn=ani dmprefix=ANI

3. NMSROOT\bin\perl dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM

4. NMSROOT\bin\perl dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

5. NMSROOT\bin\perl dbRestoreOrig.pl dsn=dfmFh dmprefix=FH

Clear CMF DB last:

6. NMSROOT\bin\perl dbRestoreOrig.pl dsn=cmf dmprefix=Cmf

net start crmdmgtd"

Error:

Unable to get results of job execution for device. Retry the job after increasing the job result wait time using the

option:Resource Manager Essentials -> Admin -> Config Mgmt -> Archive Mgmt ->Fetch Settings

vhamwvbarnaj Tue, 09/18/2007 - 08:57

Ok I resolved half of the problem. It did look like rights were an issue.

I am now getting the following error, and my current software versions are

LMS3.0

CS3.1

RME4.1.0

CM0012: Unable to create new version on archive $1 Action: Check if disk space is available and directory has required permissions

Thanks

Actions

This Discussion