EIGRP default-network propagation

Unanswered Question
Sep 19th, 2007
User Badges:

hallo

I have a doubt about the propagation of the default-network by a router running eigrp (in classless mode) to other routers in the same eigrp as.


Is it true that the default-network will be announced only if:

1) the router has an interface UP in that network, and

2) that network is a major network or the subnet-zero, and

3) that network is in the network statements under eigrp process.


OR


1) the defined default-network in router config will be learned through another eigrp router in the same as, and

2) that network is in the network statements under eigrp process.


for example if I have:


ROUTER-A)

interface f0/0

ip address 192.168.1.20 255.255.255.240

interface s0/0

ip address 172.16.1.1 255.255.255.252

clock rate 128000

router eigrp 100

network 192.168.1.0

network 172.16.0.0

no auto-summary

ip default-network 192.168.1.0

ip route 0.0.0.0 0.0.0.0 192.168.1.27


ROUTER A does not announce the subnet 192.168.1.16/28 as default D*


BUT IF I HAVE:


interface f0/0

ip address 192.168.1.1 255.255.255.240

interface s0/0

ip address 172.16.1.1 255.255.255.252

clock rate 128000

router eigrp 100

network 192.168.1.0

network 172.16.0.0

no auto-summary

ip default-network 192.168.1.0

ip route 0.0.0.0 0.0.0.0 192.168.1.5


THE ROUTER WILL PROPAGATE 192.168.1.0/28 as D*


Could you help me ?

best regards

francesco



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Wed, 09/19/2007 - 16:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Let's verify eigrp was enabled on that interface on the first example.


Please post the output from typing


show ip proto and show ip eigrp int

fsoffia Thu, 09/20/2007 - 23:10
User Badges:

hi Edison,

I attached a txt file with a simple test network layout and the results for the show commands you requested.


At the moment I can't use serial intefaces, so I used routers with two fastethernet, it's the same thing.


thankyou

francesco




Edison Ortiz Fri, 09/21/2007 - 19:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Not sure why D* is so important to you vs just D, but in order to have a D* you need to have an ip default network command in Router B.


For instance, if you remove this command from Router A


ip default-network 192.168.1.0


The D* reference will become D.


HTH,



fsoffia Mon, 09/24/2007 - 02:27
User Badges:

Hi Edison,

Router A is attached on a LAN tha know a def. gateway 192.168.1.27, but that gateway does not announce a default-network.

So I want Router A to announce the default network to other routers like Router B.


D* eigrp routes allow to rotate pachets that does not have other route matches in routing table, without inserting static routes like 0.0.0.0/0.


If you try to modify the Router A config, using the 192.168.1.0/28 (like in folowing config) and not the 192.168.1.16/28 subnet, on Router B you will see the 192.168.1.0/28 with D* !


ROUTER-A#sh run

Building configuration...


Current configuration : 964 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ROUTER-A

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

no ip ips deny-action ips-interface

no ip domain lookup

!

no ftp-server write-enable

!

!

!

!

!

no crypto isakmp ccm

!

!

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.240

!ip address 192.168.1.20 255.255.255.240

duplex auto

speed auto

!

interface FastEthernet0/1

description TO-ROUTER-B

ip address 172.16.1.1 255.255.255.252

duplex auto

speed auto

!

router eigrp 100

network 172.16.0.0

network 192.168.1.0

no auto-summary

!

ip classless

ip default-network 192.168.1.0

!ip route 0.0.0.0 0.0.0.0 192.168.1.27

ip route 0.0.0.0 0.0.0.0 192.168.1.5

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

end



I wish to know why eigrp with the previous config announces a D* while using 192.168.1.16/28 this not happens !


To have D* networks on routers not directly connected to def-gateways, working in every situation, must I config "ip default network x.y.z.t" on that routers and leave the router directly connected to x.y.z.t subnet simply announing x.y.z.t through eigrp without the command "ip default network x.y.z.t" ?

Is this what you want to tell me ?


thankyou best regards

francesco




Edison Ortiz Mon, 09/24/2007 - 04:09
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If you want to announce a default gateway, the best approach is:


Router A


ip route 0.0.0.0 0.0.0.0 [default gateway]


router eigrp x

redistribute static metric 1 1 1 1 1


HTH,



fsoffia Mon, 09/24/2007 - 04:55
User Badges:

yes

but if you have other static routes other than the 0.0.0.0/0 the "redistribute static" redistribute all static routes !


I don't want redistribute all static routes !

It could be useful have a loopback interface with an ip address in a subnet-zero,like following ?


interface loopback 0

ip address 192.168.5.1 255.255.255.252

router eigrp 100

network ....

network 192.168.5.0

no auto-summary

ip default-network 192.168.5.0

ip route 0.0.0.0 0.0.0.0 def-gateway


francesco




Kevin Dorrell Mon, 09/24/2007 - 06:04
User Badges:
  • Green, 3000 points or more

In that case, you can redistribute through a prefix-list so you can control what gets redistributed.


ip prefix-list static->eigrp permit 0.0.0.0/0


route-map static->eigrp permit 10

 match ip address prefix static->eigrp

 set metric 10000 100 255 1 1500


router eigrp

 redistribute static route-map static->eigrp


You can add prefixes to the prefix-list as many as you want.


Kevin Dorrell

Luxembourg


fsoffia Wed, 09/26/2007 - 04:41
User Badges:

hi Kevin,

prefix-list could be a solution

not simple but a solution...


but at the moment noone said why EIGRP announces 192.168.1.0/28 like D* and 192.168.1.16/28 like D...


why this behaviour difference ?


best regards

francesco

Edison Ortiz Wed, 09/26/2007 - 11:52
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Francesco,


I addressed this topic days ago. The D* is due to the ip default-network statement you have in the router. If you remove the ip default-network statement, the * after the D will go away.


If you issue a show ip route and look at the legend in the top, it explains what the "*" is for.


BTW, this command is classful so even if you input 'default-network 192.168.1.16' it will automatically change it to 192.168.1.0.


HTH,


fsoffia Thu, 09/27/2007 - 04:46
User Badges:

excuse me Edison,

but I want to be sure to understand the concept !

The last questions


1) you said "The D* is due to the ip default-network statement you have in the router".

The router that receive the network or announce the network "adds the *" or both ?


2) you said "BTW, this command is classful".

But the eigrp runs in classless mode with "no autosummary" !


3) If I don't have "ip default-network" on the router B that receive the network, and the router A that announce the network has "ip default-network 192.168.1.0" and interface address

192.168.1.20/28 -> on B I don't have D*

192.168.1.1/28 -> on B I have D*


It's only due to the classful property of "ip default-network command " ?


thanks

best regards

francesco


Edison Ortiz Thu, 09/27/2007 - 04:56
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

1) Yes, remove it and you will see the neighbors not having the "*" after the D.

The router that announces the network adds the D*.


2) ip default-network is not EIGRP. EIGRP uses that information for advertisement.


3) Yes, the classful property is due to the command in itself, not the underlying routing protocol. Try typing 192.168.1.20 on the ip default-network, it will automatically change to 192.168.1.0 ...


HTH,




Actions

This Discussion