CLID Calling Party Transformation

Unanswered Question
Sep 19th, 2007

I have tried to prepend 700 onto a route pattern using calling party transformation.

the call is routed to the gateway and i have debug q931 running there so I can see exactly what is the CLID.

So, for example I have a station with DN line 7820 and want to call 87555. I would like the call to arrive at the gw with 70087555 as the CLID. I have tried transformation mask and prefix 700. No joy upto now.

My RL and RG are doing no translations or transformations or anything at all like that.

What's going on here - I cannot get the 700 prepended to the DN on this explicit (87555) route pattern?

tia

Ajaz

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AJAZ NAWAZ Wed, 09/19/2007 - 12:58

ok i will try that. however, i have the options in RP screen for calling party transformation - so why doesn't it behave as expected?. At present my RG and RL are not doing any transformation for either called or calling part numbers. So there's nothing for them to override.

you see the problem is that when you apply it to RL it will impact all calls via that RL. I have created an explicit RP i.e. nnnnn and just want to tag 700 to the front of that. this requirement is part of a pilot test and so i'm not really wanting to put that at the RL level. but like i stated i will try it out anyhow and let you know.

ajaz

gogasca Wed, 09/19/2007 - 21:10

Hi Ajaz, I understand your concern,

which CCM version and how many CCM servers you have?

Could you try to recreate the RP it may be a DB change notification problem.

AJAZ NAWAZ Thu, 09/20/2007 - 01:13

hey.

I tried RL but it tags 700 to CLID even for on-net calls. my goal is apply the transformation only when calling 8XXXX pattern (off-net). problem still remains for now...

pub + 1x sub

ccm version 4.1(3) unpatched, and to this end what's the latest patch?

Abdulbaseer Mohammed Wed, 09/19/2007 - 22:23

Ajaz,

Try to see all your route patterns. Sounds like you may have a pattern 87xxx or some thing that is re routing the call.

What is 87555 translation, DN, Patter etc.

AJAZ NAWAZ Thu, 09/20/2007 - 01:34

thanks for your help gents. i've managed to resolve that. basically the RL config setting:

"Use Calling Party's External Phone Number Mask"

This was set to 'ON' and overriding the RP transformation. That was expected behavior albeit a somewhat ambiguous.

thanks for staying with me.

Ajaz :-)

Actions

This Discussion