ram memory full causes pix 501 to crash

Unanswered Question
Sep 20th, 2007

Good morning,

We have 2 pix 501 that are experiencing the same issue.

Each 15 hours the ram memory is almost full and the pix crashes, i mean, during this period the amount of memory in use is growing up and after 15 hours the are no free ram available.

Both pixes shown the problem at the same time but are not connected each other

Both pix versions are 6.3(5).

Any idea? the problem is very annoying.

Thanks a lot for your help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rajbhatt Thu, 09/20/2007 - 03:38

Hi,

Have u checked if after running a particular application that is happening.

Please check the follwoing :

sh proc will show if a particaulr porcesss is consuming the memory

sh xl count

sh conn

sh cpu usage

sh mem

sh mem blocks

sh loc

sh logg

Please check that logging is not set to buffered debug level.

Also check there are no interface errors.

Also check the config in output interpretor in case u have a cco login

Please check the syslog will show u what lead to the crash.

In case it does not have sh crash analysed by TAC

Raj

dconsulting Thu, 09/20/2007 - 03:51

Thanks for your quick answer Raj,

The problema is not related with any application we run and we have no buffered logging set up on the pix.

In fact we had this problema a few months ago and exchanged the pixes for new ones for testing purposes (with exactly the same configuration) and the problema dissapeared. But now it comes again.

The funny thing is that the pix machines are used on different connections and they filter different traffic so it seems not to have something in common....

rajbhatt Thu, 09/20/2007 - 03:54

Hi,

Then u would have to have TAC decode the sh crash.

Probably some bug related issue .

Raj

arburt Thu, 09/20/2007 - 18:48

'lo,

check the sh crash and verify if 'rms' is the thread related.

please check below details bug CSCsg98353

6.3.5 Crash/reboot cycle. Thread name: rms

Symptom:

Pix will crash and enter a reboot cycle. It will reboot continuously for several hours, then recover and operate normally until next reboot cycle.

Conditions:

So far this was observed only on PIX 501 with 6.3.5.

Workaround:

Cause of reboot cycle and recovery from cycle are unknown at this time. There is no known workaround.

Fixed in 6.3(5.125)

'gards,

arburt

dconsulting Mon, 09/24/2007 - 08:32

Hi,

After deep analisys i found that there is a lot of UDP traffic thru the pixes.

I found that increasing the UDP timeout the memory gets full more slowly (of course i know this is not the right thing........)

Have you ever seen this behaviour with UDP?

Kind rgds

dconsulting Wed, 10/10/2007 - 06:03

Hi again,

Does really anybody haven't seen this error before?

We are experiencing the problem with another pix (new one) that only has one ipsec tunnel and some port translations set up on it.

The rest of the configuration is completely factory default (it is located on a different building with different network setup also.....)

The main problems is that we can't leave them crash and then analyse the logs because the are on duty.....

Any new idea? Is it possble that anyone haven't seen this error in the past?

Kind rgds.

Actions

This Discussion