Configuration of Cisco 876 router

Unanswered Question
Sep 20th, 2007

Hi. As I have never connected a router to any ADSL including ADSL over ISDN as this is the case I would ask for your help with the configuration(I will just include the relevant configuration):

interface ethernet0

no shut

ip address x.x.x.x y.y.y.y

ip tcp adjust-mss 1452

ip nat inside

no ip directed-broadcast

!

interface atm0

no shut

no ip address

bundle-enable

dsl operating-mode auto

!

interface atm0.1 point-to-point

no ip address

no ip directed-broadcast

no atm ilmi-keepalive

pvc 1/35

pppoe-client dial-pool-number 1

!

interface dialer1

ip address negotiated

mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname username - username ISP provided

ppp chap password password - password ISP provided

!

ip nat inside source list 1 interface dialer1 overload

!

ip classless

ip route 0.0.0.0 0.0.0.0 interface dialer 1

access-list 1 permit x.x.x.x z.z.z.z

I have several users that will need to access the Internet using PPPoE(currently there is only one user that connects over ADSL modem which this router will replace), the authentication method is CHAP, PVC is 1/35 and I got a static IP address from the ISP. I referenced this configuration from several Cisco configuration.

Should anything be added or removed. Any help is greatly appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Thu, 09/20/2007 - 19:52

hi

the config seems to be fine.

get it connected with the adsl line and start surfing.

regds

Actions

This Discussion