Strange dropped packet problem

Unanswered Question

Hi all,


I've come across a strange problem today with dropped packets through an 871. Both Vlan1 and F4 show a large number of input drops, but no other errors. CEF is enabled on both interfaces, and I have also tried with fast switching and increasing the input buffer to 4000, which stops the interface input drops increasing, but doesnt stop the dropped ping packet problem. Any ideas would be greatfully received!


Thanks,

Chris


From F4 to a host on Vlan1:

Sending 1000, 100-byte ICMP Echos to 88.21.n.n, timeout is 2 seconds:

!!!!!!!!!!!!!.!.!!.!!!!!!!!!!!!!.!.!!!!!!!!!.!.!!!!!!!!!!!!!.!!!!!....

.!!.!!...!..!..!!!!!!!!!!!.....!!...!..!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!


Vlan1 is up, line protocol is up

Hardware is EtherSVI, address is 001a.6ce9.7d68 (bia 001a.6ce9.7d68)

Internet address is 172.20.45.2/16

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/4000/6601683/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/100 (size/max)

5 minute input rate 202000 bits/sec, 252 packets/sec

5 minute output rate 502000 bits/sec, 200 packets/sec

35406939 packets input, 3701499054 bytes, 1357 no buffer

Received 47495 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

33159172 packets output, 4246981770 bytes, 0 underruns

0 output errors, 1 interface resets

0 output buffer failures, 0 output buffers swapped out


interface Vlan1

ip address 172.20.45.2 255.255.0.0

ip access-group 103 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache same-interface

ip route-cache flow

ip policy route-map CLEAR_DF

hold-queue 4000 in

hold-queue 100 out


interface FastEthernet4

ip address 88.21.n.n 255.255.255.248

ip access-group 104 in

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1400

ip nat outside

ip inspect FW out

ip virtual-reassembly

ip route-cache same-interface

ip route-cache flow

ip tcp adjust-mss 1400

duplex auto

speed auto

crypto map VPN

hold-queue 4000 in



Vlan1 is up, line protocol is up

Internet address is 172.20.45.2/16

Broadcast address is 255.255.255.255

Address determined by non-volatile memory

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is 103

Proxy ARP is disabled

Local Proxy ARP is disabled

Security level is default

Split horizon is enabled

ICMP redirects are never sent

ICMP unreachables are never sent

ICMP mask replies are never sent

IP fast switching is enabled

IP fast switching on the same interface is enabled

IP Flow switching is enabled

IP CEF switching is enabled

IP CEF Flow Fast switching turbo vector

IP multicast fast switching is enabled

IP multicast distributed fast switching is disabled

IP route-cache flags are Fast, Flow cache, CEF, Full Flow

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Policy routing is enabled, using route map CLEAR_DF

Network address translation is enabled, interface in domain inside

BGP Policy Mapping is disabled

WCCP Redirect outbound is disabled

WCCP Redirect inbound is disabled

WCCP Redirect exclude is disabled

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
owillins Wed, 09/26/2007 - 11:04
User Badges:
  • Silver, 250 points or more

By default, all layer 2 ports are in dynamic desirable mode, so the layer 2 port tries to form a trunk link and sends out DTP packets to the remote device. When a layer 3 interface is connected to a layer 2 switchport, it is not able to interpret these frames, which results in Input errors, WrongEncap errors, and Input queue drops.

In order to resolve this, change the mode of the switch port to static access or trunk as per your requirement.


Actions

This Discussion