shaping configuration does not show up in running-config

Unanswered Question
Sep 20th, 2007
User Badges:

I have a Cisco827-4v c820-k9osv6y6-mz.122-15.T14.bin


I am setting up QoS CBWFQ over IPsec GRE VPNs tunnels


My Issue is regarding Shaping inside my parent policy.


In class-map configuration mode inside policy-map configuration mode I can type shape average 512000 5120 command


BUT when I check running-config again

the line shape average 512000 5120 does not exist.


Any Idea?


Chek the text below


Avig_sayula#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Avig_sayula(config)#policy-map AVIG

Avig_sayula(config-pmap)#class class-default

Avig_sayula(config-pmap-c)#shape average 512000 5120

Avig_sayula(config-pmap-c)#service-policy voice-policy


Avig_sayula#sh running-config


policy-map AVIG

class class-default

service-policy voice-policy





Rgds......

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
mfreijser Fri, 09/21/2007 - 04:46
User Badges:
  • Bronze, 100 points or more

It could be that the command 'shape average 512000 5120' is a default value, that could be the reason that it doesn't show up in the configuration.


You'll also see that kind of behaviour when you create a ISAKMP policy with default values. Some line seem missing but they are really there.


You can double-check your configuration in the Cisco SDM (not the Express version of SDM!). It should be possible to view the contents of the policy-map there.


Please rate if the post is usefull!


Regards,


Michael

eespadasn Fri, 09/21/2007 - 17:52
User Badges:

Michael

I really appreciate your time.


I have tried with other parameters something like that 'shape average 128000 1280', 'shape average 384000 3840' and is the same problem

Joseph W. Doherty Sat, 09/22/2007 - 14:27
User Badges:
  • Super Bronze, 10000 points or more

I'm not currently at a box to test with, but the class-default is a bit different from other classes. Might be a shaper isn't supported in that particular class, or you might need to state something like no fair-queue or use a bandwidth statement. Might also need to change the reserve bandwidth allocation.


Also if have logging active, check it. I've seen instances where command lines appear to be accepted, when they are actually rejected but only the syslog indicates why.

eespadasn Sun, 09/23/2007 - 16:48
User Badges:

Joseph

I really appreciate your time.

The shaper command is supported in class-default look below.

Avig_sayula(config)#policy-map AVIG

Avig_sayula(config-pmap)# class class-default

Avig_sayula(config-pmap-c)#?

QoS policy-map class configuration commands:

bandwidth Bandwidth

drop Drop all packets

exit Exit from QoS class action configuration mode

fair-queue Enable Flow-based Fair Queuing in this Class

no Negate or set default values of a command

priority Strict Scheduling Priority for this Class

queue-limit Queue Max Threshold for Tail Drop

random-detect Enable Random Early Detection as drop policy

service-policy Configure QoS Service Policy

shape Traffic Shaping


I created another class and command shape does not show up yet in running-config also I was checking syslog messages and I did not receive nothing regarding shape command.


I stated bandwidth command first and then no fair-queue command and I can see them in running-config but shape command is not posible.




Joseph W. Doherty Sun, 09/23/2007 - 17:15
User Badges:
  • Super Bronze, 10000 points or more

I just looked at software advisor. Didn't find your version, c820-k9osv6y6-mz.122-15.T14.bin, listed. Even though syntax accepted at command line, perhaps you need to try another version. Ones I found listed are:


12.4(5c)

c820-k9osv6y6-mz.12.4-5c


12.3(11)YZ2

c820-k9osv6y6-mz.12.3-11.YZ2


12.3(11)T12

c820-k9osv6y6-mz.12.3-11.T12


12.2(13)ZH9

c820-k9osv6y6-mz.12.2-13.ZH9

eespadasn Mon, 09/24/2007 - 12:07
User Badges:

Joseph.


thanks for you time.


May be this version was deferred


Change IOS version is my last option but I must to do. It is a bad notice for financial deparment.


Thank joseph for you help.

Actions

This Discussion