UNITY - Foundation Agent error - Pagefile question

Unanswered Question
Sep 20th, 2007

Good Day,

We had a issue today where IIS admin, SMTP, WWW, IMAP, POP services unexpectedly shutdown.

Looking through the event viewer I see that there are numerous "Foundation Agents" errors. Event ID: 2099

"This can be caused by a low memory condition"

I then look at our pagefile and see that it's 4GB in size on our C: drive(8GB). I then went into the control panel on unity and looked up the virtual memory allocation and our Initial and Maximum allocation for the pagefile is the same (4095MB)

My question is shouldn't the pagefile be set to 2095 initial and 4095 maximum? or x1.5 RAM installed (3500MB)?

We have 2GB ram in the unity server.

I will reboot the server tonight as this should resolve the Foundation Agent errors.

Screenshot of foundation error and pagefile attached.

Thanks

Justin

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
bwilmoth Wed, 09/26/2007 - 11:42

The Foundation Agent error is associated with Hard disk monitoring.it may be a cosmetic error due to a conflict with certain

MSupdates, but it may also indicatea problem with the disk. Please run chkdsk /R

Justin Brenton Wed, 10/03/2007 - 11:20

Thanks for your reply.

I'll try chkdsk.

This is only happening on our publisher and not subscriber so I'm not sure how it would affect 1 server and not the other.

asomanya Wed, 09/26/2007 - 13:31

>My question is shouldn't the pagefile be set to 2095 initial and 4095 maximum? or x1.5 RAM installed (3500MB)?

Microsoft's recommendation has always been to have both figures the same to disallow the growing of the page file. This helps in reducing fragmentation.

Richard Bradfield Wed, 10/03/2007 - 23:05

there seesm to have been a lot of problems with HP foundation agent, I got the memory low error on a new MCS7835 reading various articles, I have just disabled the Foundation agent service.

Justin Brenton Thu, 10/04/2007 - 11:34

I feel as though disabling the service will cause more issue's in the long run.

Justin Brenton Fri, 10/05/2007 - 10:02

I have ran chkdsk /f and now the error only appears once when rebooting instead of every 2 minutes, I will schedule a time to do the chkdsk /r function but this will need downtime of over 1 hr.

Actions

This Discussion