Cannot ping host

Unanswered Question
Sep 21st, 2007

I have connected 2 cisco routers with back to back DCE/DTE cable. I have configured both serial interfaces with 192.168.2.x range. Also on one router I have configured the ethernet interface to and have a host with ip connected to it. Rip is configured on both routers but from the other router I can only ping but not the host! what is the reason?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Fri, 09/21/2007 - 12:09


The first things that I would check to investigate this problem is whether the host has the right default gateway configured. If the host is attempting to respond to 192.168.2.x then it needs to have its default gateway be



aconticisco Fri, 09/21/2007 - 12:17

yes the host gateway is set to

In fact I do not know if it helps but from the router which has the ethernet directly connected and not learned through rip I can ping the host even when connected with telnet on serial interface with 192.168.2.x

wilson_1234_2 Fri, 09/21/2007 - 13:21

Are you sure RIP is working?

Are there routes to the network in the remote side router?

Is it RIP version 1?

Could it be a discontiguous netwok issue?

aconticisco Sat, 09/22/2007 - 07:52

remote side router

R [120/1] via, 00:00:06, Serial0

C is directly connected, Serial0

local router

C is directly connected, Ethernet0

C is directly connected, Serial0

using rip v1, host connected with local router ethernet port and ping ok from local router.

from remote router can ping ethernet interface of local router but cannot ping host

Edison Ortiz Sat, 09/22/2007 - 08:53

It sounds like you have FW enabled in the host that only allows ICMP from devices within the same subnet.

Even telneting to the local router on its serial interface, will produce an ICMP packet sourcing from the ethernet interface.

You can alter this behavior by using this command.

ping source [serial ip]

on the local router and see if the host respond to the ICMP.

If this is WindowsXP, most often Windows FW is enabled. Check for that ...

aconticisco Sun, 09/23/2007 - 11:11

Thank You I think this could be the reason. Unfortunately that command gave me an error when I tried from local router;

r2#ping source


% Invalid input detected at '^' marker.

Tried to disable Windows firewall however it did not fix the problem.

Edison Ortiz Mon, 09/24/2007 - 17:22

Perhaps you have an old IOS.

Try with extended ping... Example,

ping [enter]

and follow the prompts, when you get to the source address, enter it there.

timothykerr Mon, 09/24/2007 - 19:23

When using the extended ping command (ping [enter]), in order to specify a source address or interface you need to hit y when asked about extended commands.



This Discussion