WLC and DHCP

Unanswered Question

Hello All,


I have a WLC running 3.2.116.21. It is trunked with dot1q and the specific VLANs are allowed. I have defined an interface (call it Outside) for vlan 100 and assigned it an appropriate address. Also the defined DHCP server is a Cisco router acting as a gateway off of the wired LAN. Now, I've also defined a WLAN and tied it to the Outside interface. My problem is that when a wireless client successfully associates they get no IP address. The kicker is that when I do debug on the WLC I see the client's DHCP DISCOVER message go out. And then I see the router's DHCP OFFER message reply. However there is no DHCP ACK and the client never accepts the offered ip address. On another note, this works just fine for a DSL vlan that we've setup in exactly the same manner. DSL router is connected to an arbitrary VLAN and is acting DHCP server. The DSL VLAN is tied to a WLAN and clients can associate and recieve DHCP address no problem. I've rebooted the WLC and no affect, also I've tried disabling/enabling the DHCP proxy. No change in behaviour. I'm definitely all ears to any suggestions!!!!


TIA,

Andrew


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Okay, found out what it was. Just not sure why. In no way related to DHCP issues. Noticed that when I statically assigned an address I still could not communicate. So, after some floundering I deselected static WEP as the security mechanism and used WPA with passcode. Voila! Worked like a champ...my new question then is this...why? The static wep key worked just fine for the DSL vlan instance but not for the Outside vlan.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode