Policy Routing for Router Generated Traffic

Answered Question
Sep 23rd, 2007
User Badges:

This may be a little out of place since it is voice related, but the question is policy routing.


I need to be able to set the next hop for traffic being generated by the session target command on a voip dial-peer. This target of this peer is reachable via a SIP Trunk (point to point T1). Using static routes is not acceptable, as there are web sites that fall into the network statements and we only want voice traffic on this link. I have tested various route-maps by placing them on the loopback interface that H323 is bound to, the serial link that the router's default gateway (DS3) is on, as well as the data and voice gig interfaces. Regardless of the interface the route-map is on, I cannot control the next hop. Since this traffic is being generated by the router and not leaving an interface I am not sure where to apply the route-map. Maybe policy-routing is not the method I should be using.


Any ideas?


Thanks!!!


Adam

Correct Answer by Richard Burts about 9 years 7 months ago

Adam


It sounds to me like Policy Based Routing is what you are looking for. In general you assign the route map on the interface on which the traffic arrives (as you have stated). For traffic generated on the local router you use:

ip local policy route-map

Give it a try and let us know if that works.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Correct Answer
Richard Burts Sun, 09/23/2007 - 12:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Adam


It sounds to me like Policy Based Routing is what you are looking for. In general you assign the route map on the interface on which the traffic arrives (as you have stated). For traffic generated on the local router you use:

ip local policy route-map

Give it a try and let us know if that works.


HTH


Rick

mwadam Sun, 09/23/2007 - 17:34
User Badges:

Rick,


Thanks for the reply.

This is what I have been doing. I applied the route-map to the loopback which is where H323 traffic should originate, but since CallManager passes the call to that interface and then the dial-peer is processing it, it is no longer passing thru that interface. This is why I tried other interfaces with no success.

Richard Burts Sun, 09/23/2007 - 18:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Adam


The fact that traffic is not passing through the loopback interface is why I suggested that you try to use ip local policy. Traffic that is generated by the router is not processed through any interface and that is why ip local policy was introduced by Cisco.


HTH


Rick

mwadam Sun, 09/23/2007 - 18:39
User Badges:

Rick,


My fault, didn't pick up on the command difference. I apologize.


I will be giving this a try tomorrow and will let you know.


Thanks!!!


Adam

mwadam Mon, 09/24/2007 - 15:23
User Badges:

Rick,


I implemented the ip local policy and it worked perfectly! I appreciate all of your help!!!

Joseph W. Doherty Sun, 09/23/2007 - 12:23
User Badges:
  • Super Bronze, 10000 points or more

Perhaps?


(from 12.0 config guide)


Enable Local PBR


Packets that are generated by the router are not normally policy-routed. To enable local PBR for such packets, indicate which route map the router should use by using the following command in global configuration mode:


Command Purpose

ip local policy route-map map-tag

Identify the route map to use for local PBR.

All packets originating on the router will then be subject to local PBR.


Use the show ip local policy command to display the route map used for local PBR, if one exists.


mwadam Sun, 09/23/2007 - 17:35
User Badges:

Thanks for the reply.


This sounds more like what I am looking for. I will test it tomorrow and let you know the results.


Thanks again!

mwadam Mon, 09/24/2007 - 15:24
User Badges:

I implemented the ip local policy and it worked perfectly! I appreciate all of your help!!!

Richard Burts Tue, 09/25/2007 - 02:29
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Adam


I am glad that the suggestion from Joseph and from me helped you resolve your problem. Thank you for using the rating system to indicate that your problem was resolved (and thanks for the rating). It makes the forum more useful when people can read about a problem and can know that they will read a successful solution to the problem.


I encourage you to continue your participation in the forum.


HTH


Rick

Actions

This Discussion