7921 phone roam "sticky"

Unanswered Question
Sep 23rd, 2007
User Badges:

I have 7921 phones along with 1242 LWAPP APs. I have noticed the phones resist roaming to an AP that is closer (stronger signal). I did some testing on some APs that did not have any other associations. What I found was the phone would cling to the AP that it originally associated with. Even when the signal showed 1 bar on the phone and I was standing 2 feet away from another AP, the phone would not roam. The voice quality was suffering, but the phone would not let go of the distant AP. If I powered off the phone and powered it back on, it would associate to the AP that was 2 feet away. When I walked away, it clung to that AP. Only when the signal was so weak that is was effectively gone, would the phone switch to another AP. I am using WPA-PSK to authenticate the phone. I am running 4.1.171.0 on the controllers. The phone loads are from the latest device pack in CallManager. I have a dedicated voice VLAN defined on the APs. I have WMM Policy, 7920 AP CAC, and 7920 Client CAC all disabled. Does anyone know how to make these phones ?less sticky??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
john.preves Sun, 09/23/2007 - 20:56
User Badges:
  • Silver, 250 points or more

What are the power settings on your phones and AP's?


I expect they are too high. You have to have smaller cells (lower powered AP's) and lower power on the phones in order to get them to roam properly.

jcvanwyng Mon, 09/24/2007 - 05:56
User Badges:

It is my understanding that the phone and the AP negotiate the power setting on the phone. Regardless, I want to phone to roam to a stronger AP when it gets below 2 bars. It will not. It should roam before voice quality suffers. I can hear clipping and the voice will sound fuzzy. I know these phones avoid roaming by design. I just want them to roam more quickly than they do now.

migilles Tue, 09/25/2007 - 04:29
User Badges:
  • Cisco Employee,

So does the current signal get below -80 dBm?

Are you using 5 GHz or 2.4 GHz?

With 5 GHz, must abide by 802.11h and passively scan the DFS channels (UNII-2).

If on call, may not receive the beacon that comes out every 100ms as the phone can not wait that long when on call. When received the phone can probe that channel for the phone's configured network, to see if there are Aps on that channel that have the phone's SSID or not.


We are working on some items to make the phone more agressive in roaming though.


Would suggest opening a TAC case for support assistance.

LUIGI PIETRONAVE Tue, 04/08/2008 - 09:53
User Badges:

Hi,


did You solved that issue ? I've several issue related to 7921, like:

- frequently re-registering

- a lot of network busy error

- 7921 not connecting to nearest ap


Many thanks in advance


Luigi

jcvanwyng Wed, 04/09/2008 - 07:16
User Badges:

Luigi,


I'm not sure. However I did eventually upgrade the phone load to CP7921G-1.0.5. I don't seem to be having the problems roaming that I was having before.


Joel

nrparks024 Sun, 05/18/2008 - 08:41
User Badges:

upgrade your phones to 1.1.1. there are roaming improvements and survey improvements.

migilles Sun, 05/18/2008 - 21:50
User Badges:
  • Cisco Employee,

Some enhancements were made to the roaming mechanism to make it more aggressive which is required in some environments where an aop association can be short lived.


Also a comment on the original post, it showed that WMM and AP CAC were disabled, which means QBSS will not be enabled as well. Should always have WMM enabled per the 7921G Deployment Guide, but some 3rd party APs may not support QBSS, where a fix is available in 1.0(5) that addresses an issue in regards to only roaming on BSS loss when QBSS is not enabled.

Actions

This Discussion