Can't get WEP auth to work with 1240AG

Unanswered Question
Sep 24th, 2007
User Badges:

I can get a linux client (debian using atheros card) working fine with no authentication in open mode.


However, if I set up 128bit WEP (4 keys) and enter those exact keys on my linux client. It can't associate.


I've quadruple checked the keys on both the AP and the client and they do match.


The only odd thing that I've seen is that if I use the 1240AG Express Security setup page to enter the WEP keys, I only end-up with one defined key in the IOS config. So I manually enter the WEP keys via IOS.


Is there some trick to entering all 4 WEP keys in that GUI, or are you supposed to only end-up with one key?


Also, I've set my transmit-key to 4, if that makes a difference.


Also, is there a way to display the keys in the IOS config without that level 7 scrambing, so I can verify my settings on the AP?


Thanks,

Bob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rwingraham Mon, 09/24/2007 - 16:02
User Badges:

Ok, if it's worth anything to anyone else, I've answred my own quesstions:


1. You enter all four keys in the Security screen of the web GUI. The Express Security screen is retarded and only records one key, no matter what you do.


2. I had to make WEP encryption optional and then my client associated right away with 128bit WEP.


Now I'm trying to figure out how to enable encryption on the client.


Bob

Actions

This Discussion