Error assigning port to VLAN on 877

Answered Question

I've got an 877 running IOS 12.4.6, and I want to create two VLANs (1 & 26)

1 already exists, and all the ethernet ports are already in it.

I create VLAN 26 by doing:

int vlan 26

ip add x.x.x.x 255.255.255.0

Now, if I go to an interface and do:

int f0

switchport mode access vlan 26

I get the message back:

%Access VLAN 26 does not exist. Please add it to vlan database

What am I missing ?

Thanks,

GTG

I have this problem too.
0 votes
Correct Answer by mahmoodmkl about 9 years 2 months ago

Hi

First change the mode to vtp server i.e

vlan database#vtp server

then create vlans.

Thanks

Mahmood

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
mahmoodmkl Tue, 09/25/2007 - 02:29

Hi

I think u need to first create a vlan before u assign any port to it.what the message says that u need to create a vlan first.ie.

router#vlan database

router(vlan database)# vlan 26 name (anyname)

Thanks

Mahmood

Minor progress:

Router#vlan database

Router(vlan)#vlan 26 name "Clients"

VLAN 26 added:

Name: Clients

Router(vlan)#show

VLAN ISL Id: 1

Name: default

Media Type: Ethernet

VLAN 802.10 Id: 100001

State: Operational

MTU: 1500

Translational Bridged VLAN: 1002

Translational Bridged VLAN: 1003

VLAN ISL Id: 26

Name: Clients

Media Type: Ethernet

VLAN 802.10 Id: 100026

State: Operational

MTU: 1500

Router(vlan)#exit

In CLIENT state, no apply attempted.

Exiting....

Router#vlan database

Router(vlan)#show

And VLAN26 has disappeared....

GTG

Actions

This Discussion