QOS Not matching voice traffic

Unanswered Question
Sep 25th, 2007

Hey all,

I have the following policy map on the outbound direction of my MPLS interface. The purpose is to give a priority queue for voice, and to make traffic to our ERP system the next highest priority. However, we are getting garbled voice quality. I did a "show policy-map int multilink 2" and it is showing 0 voice packets, but lots of ERP packets.

Am I correct assuming the attached output means no packets are getting into that priority queue? And any thoughts why? I followed ShoreTel's guide, and either DSCP EF, or the access-list method will work.

class-map match-any badtraffic

match protocol gnutella

match protocol kazaa2

class-map match-any email

match access-group name ACLemail

class-map match-any qad

match access-group name ACLqad

match access-group name ACLimportant

class-map match-any voice

match dscp ef



policy-map pmap_mpls

class voice

priority 512

class qad

set dscp af21

bandwidth remaining percent 50

class email

set dscp af11

bandwidth remaining percent 25

class badtraffic

set dscp default

bandwidth remaining percent 1

class class-default

set dscp default

bandwidth remaining percent 24

random-detect dscp-based

Service-policy output: pmap_mpls

Class-map: voice (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp ef (46)

0 packets, 0 bytes

5 minute rate 0 bps

Match: access-group name ACL_shoretel_voice

0 packets, 0 bytes

5 minute rate 0 bps


Strict Priority

Output Queue: Conversation 264

Bandwidth 512 (kbps) Burst 12800 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: qad (match-any)

18668 packets, 1369565 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name ACLqad

7580 packets, 704662 bytes

5 minute rate 0 bps

Match: access-group name ACLimportant

11088 packets, 664903 bytes

5 minute rate 0 bps

QoS Set

dscp af21

Packets marked 18454


Output Queue: Conversation 265

Bandwidth remaining 50 (%)Max Threshold 64 (packets)

(pkts matched/bytes matched) 15195/1179721

(depth/total drops/no-buffer drops) 0/0/0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
michaelchoo Tue, 09/25/2007 - 16:11

I noticed that you presume the voice packets have been marked with DSCP EF. How is your switch configured? Do you have appropriate DSCP-to-CoS mapping and CoS-to-DSCP mapping? Assuming you use Cisco Catalyst switch, make sure you use AutoQoS to configure the switch QoS, then fine-tune the configurations to include your ERP, email, and P2P traffic.

ariesc_33 Wed, 09/26/2007 - 03:17

im not sure but you may need to define RTP on your class map for voice.

ariesc_33 Wed, 09/26/2007 - 03:18

im not sure but you might need to define RTP on your class map for voice.

Pavel Bykov Wed, 09/26/2007 - 04:14

Correct your configuration with the following commands:

class-map match-any voice

match protocol rtp audio

Hope this helps.

Please rate all helpful posts.

emphillips00 Wed, 09/26/2007 - 08:37

Hey guys,

I have a message off to the phone installers to verify how they are marking packets on the phones.

In the mean time I have added rtp audio to the class.

I will definitely update this post once I find out what the issue is.

Thanks a bunch for everyone's prompt replies.


Pavel Bykov Wed, 09/26/2007 - 09:33

Cisco phones automatically mark voice as EF.

Then switches need:

1. mls qos enable

2. on each port: mls qos trust dscp and mls qos trust device cisco-phone (or similar)

3. On trunks: mls qos trust dscp

Otherwise all marking will automatically be remarked to 0 (default).

cfolkerts Wed, 09/26/2007 - 10:22

This is a Shoretel phone system so it would be tough to match the protocol if Cisco is unaware or does not have their protocol in NBAR.

I would reference the Shoretel docs to find out which udp ports they use for voice. Then I would use an access-list to define the traffic. Or if the IP phones mark the traffic, I would configure on your edge switches mls qos trust cos and apply the appropriate COS-DSCP mapping.

As a side note, since you are utilizing PPP multilink I would suggest implementing the following commands to the configuration as well.

Under the multilink int

R1(config-if)#ppp multilink fragment delay 10

R1(config-if)#ppp multilink interleave



This Discussion