Speed and Duplex set to Auto for Trunk Ports?

Unanswered Question
Sep 25th, 2007
User Badges:

Hi all,


Why do trunk Ports have to be set to auto for Speed and duplex? I have a 4006 going to 2960 and 3550 if I set the ports to 100, full the link remains down, if set to auto link comes up (config on both sides)? Also, a I have core switch that is the VTP server 4510 connected to the 4006. If I connect an access switch to the 4006 the VTP info does not get picked up (automatically, if configured it does). If I directly connect to the 4510 it does automatically, why is this?


Thanks,

Nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
nambi_gct Tue, 09/25/2007 - 22:14
User Badges:
  • Bronze, 100 points or more

can you pls post the trunk interface configurations.

glen.grant Wed, 09/26/2007 - 03:23
User Badges:
  • Purple, 4500 points or more

Not sure I have ever heard that , both sides must match exactly if one side is hardcoded 100/full the other side must be also. As long as the vtp domain name and password if it has one match the access switch hooked to the 4006 should pick up the vtp info. Its possible that the 2960 has an old vtp domain name in it , one way to see is to delete the vlan.dat file then reload the access switch and see if it will work.

nickhesson Wed, 09/26/2007 - 09:04
User Badges:

If on 4006 COS 6.1:

set port speed 2/34 100

set port duplex 2/34 full


and on the 3550 IOS12.2:


interface fa0/24

speed 100

duplex full


The ports with not link up. If I set the setting back to auto. The ethernet link comes up.


As far as the VTP question. That is what i did, delete the vlan.dat, reloaded, and I am use to the switch automatically pick up the right domain name. And it would if I connect to my core switch, if connect to the 4006, it does not. Just asking, not a problem.


thanks for your time,

Nick

Don Saling Wed, 09/26/2007 - 11:16
User Badges:

Are you using a crossover cable between the switches (which is the right way to connect them)? If you set speed or duplex to anything other than auto, the auto-mdix feature is disabled and a straight-through cable between the switches would not work.

nickhesson Wed, 09/26/2007 - 15:03
User Badges:

Thanks, that is the answer I was looking for. I will use a crossover.


Thanks,

Nick

Actions

This Discussion