nvram last config not displaying

Answered Question
Sep 25th, 2007
User Badges:

Hi Experts,


Is there any changes in the latest IOS version, as when I do " sh run" , the statements below are not displaying..


---examples----

! Last configuration change at 01:31:17 GMT Thu Aug 30 2007 by sasadm

! NVRAM config last updated at 01:31:59 GMT Thu Aug 30 2007 by sasadm



Thus, I wont be able to know who did the changes on the router..


Thanks,



Correct Answer by Richard Burts about 9 years 8 months ago

Cindy


This is an interesting problem with a simple solution. If the router believes that it really knows the correct time and date (either it has the calendar chip, it is running ntp and has learned time, or has executed clock set) then it will put those lines into the config. And if the router does not believe that it really knows the correct time then it does not put those lines.


My suggestion is to get correct time into the router (ntp or clock set), then make a config change, and then look at show run and see if the lines do not show up again.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Richard Burts Wed, 09/26/2007 - 07:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cindy


This is an interesting problem with a simple solution. If the router believes that it really knows the correct time and date (either it has the calendar chip, it is running ntp and has learned time, or has executed clock set) then it will put those lines into the config. And if the router does not believe that it really knows the correct time then it does not put those lines.


My suggestion is to get correct time into the router (ntp or clock set), then make a config change, and then look at show run and see if the lines do not show up again.


HTH


Rick

cindylee27 Thu, 09/27/2007 - 20:46
User Badges:

Hi Rick,

Sorry for the late reply..You are indeed very right..:)


it was due to the ntp md5 password was mismatch..change that and it works like a charm..


But this brings me to another issue..

Well, My Core Switch able to sync with the Core Router but my dist sw not able to sync with the Core Switch. Any problems with the config below?

I did a sh ntp status as well..Any more info u need can let me know..


Thanks..


Distribution Sw Configuration

------------------------------


interface Vlan1

no ip address

no ip redirects

no ip proxy-arp

no ip route-cache

shutdown

ntp broadcast client


interface Vlan3

ip address 15.12.3.1 255.255.255.0

no ip redirects

no ip proxy-arp

no ip route-cache

ntp broadcast client


ntp authentication-key 888 md5 4444C124B7A10401C1432 7

ntp authenticate

ntp trusted-key 888

end


SGDistSW#sh ntp status

Clock is unsynchronized, stratum 16, no reference clock

nominal freq is 119.2092 Hz, actual freq is 119.2092 Hz, precision is 2**18

reference time is 00000000.00000000 (00:00:00.000 GMT Mon Jan 1 1900)

clock offset is 0.0000 msec, root delay is 0.00 msec

root dispersion is 0.00 msec, peer dispersion is 0.00 msec


Core Sw Configuration

----------------------


interface Vlan3

ip address 15.12.3.253 255.255.255.0

ip access-group 103 in

ip access-group 103 out

no ip redirects

no ip proxy-arp

ntp broadcast key 888

standby 3 ip 15.12.3.254

standby 3 priority 130

standby 3 preempt


ntp authentication-key 888 md5 1111383508155517101234 7

ntp authenticate

ntp trusted-key 888

ntp clock-period 36028921

ntp source Loopback0

ntp server 15.12.255.221 key 888

ntp server 15.13.255.249 key 888 prefer

end


SGCoreSW#sh ntp status

Clock is synchronized, stratum 7, reference is 15.13.255.249

nominal freq is 119.2092 Hz, actual freq is 119.2088 Hz, precision is 2**18

reference time is CAA7049B.6BE2D47B (04:42:03.421 GMT Fri Sep 28 2007)

clock offset is 5.6022 msec, root delay is 40.53 msec

root dispersion is 140.29 msec, peer dispersion is 2.79 msec






Richard Burts Fri, 09/28/2007 - 05:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cindy


I do not see anything on the distribution switch that tells it what to request time from. I suggest that you add this to the switch config and let us know how it works:

ntp server 15.12.3.253


HTH


Rick

cindylee27 Sun, 09/30/2007 - 04:23
User Badges:

Thanks Rick..

I tried ur method n took it out after that.. It works like a charm.. believe that the time drift too far away thats y the ntp not able to do sync..


Now is working.. :) thanks a lot!


Richard Burts Sun, 09/30/2007 - 11:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cindy


I am glad that you got it working. Thank you for posting back to this thread and indicating that you had resolved the issue. It makes the forum more useful when people can read about an issue and can know what suggestion led to resolution of the issue.


HTH


Rick

uubozou11 Mon, 10/01/2007 - 09:00
User Badges:

On that note, how does an author mark his/her post as solved?

Richard Burts Mon, 10/01/2007 - 09:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jimmy


The easy part of the answer is that if you are the author/origin of the thread there is a box that you can check on each of the posts that other people have made. If you select that box on the post that helped you solve your problem then it marks the thread as solved.


It is a somewhat different situation if you are the author/origin of a thread and if you find your own solution so there is not someone else's post that you can check the box. I do not believe that there is any ability to check your own ratings. I am not sure what you would do to mark it as solved if you can not attribute the solution to someone else.


HTH


Rick

Actions

This Discussion