%PM-4-ERR_DISABLE: link-flap

Unanswered Question
Sep 26th, 2007

Hi there,

We've been having speed issues getting out onto the Internet and I'm trying to locate the source of the problem by eliminating a few possibilities. One being mismatched switch config between us and the ISP. Our switch is a 3550G running IOS and the port is a static access port in default vlan 1. This connects via fibre to our ISP's switch which is a 6500 series running Catos. Unfortunately I have no knowledge of Catos so can't definitively decipher the copy of the port config they've sent me. They assure me that their port is a static access port and is hardcoded to 1000Full so I'm trying to make ours hardcoded to 1000Full rather than autonegotiate which it is now.

I'm trying to set the gig port of our 3550G to hardcoded 1000full by issuing the command 'speed nonegotiate'. However every time I do this the port goes error disabled with this message "%PM-4-ERR_DISABLE: link-flap error detected on Gi0/1, putting Gi0/1 in err-disable state".

The port will not come up unless the command 'no speed nonegotiate' is issued, i.e. I can't hard code it, it won't come up unless it is set to autonegotate.

The following is what it negotiates to:

Full-duplex, 1000Mb/s, link type is autonegotiation, media type is SX

The ISP's switch port config that they've sent me is:

#module 6 : 16-port 1000BaseX Ethernet

set vlan 361 6/2

set port name 6/2 u361 CompanyName

set trunk 6/2 off negotiate 1-1005,1025-4094


switch3.lhr3> (enable) sh port 6/2

* = Configured MAC Address

Port Name Status Vlan Duplex Speed Type

----- -------------------- ---------- ---------- ------ ----- ------------

6/2 u361 CompanyName connected 361 full 1000 1000BaseSX

Can anybody let me know if their port is indeed hardcoded to 1000Full or is it autonegotiate? And also what could be the reason that our port goes error disabled whenever the command 'speed nonegotiate' is issued.

Thanks in advance.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
JORGE RODRIGUEZ Wed, 09/26/2007 - 08:49

Pete, on the ISP switch side the port is hardcoded to full duplex.

Duplex = when indicated full it is because it is hardcode / otherwise it would indicate

Duplex auto

Speed = means 10/100/ or 1000 the port is hardcoded to in this switch case is 1000 otherwise it would indicate Speed auto

type = means link type , in this case it is 1000BaseSX


the port may go into error disable for various physicall reasons udld for example unidirectional detection as suppose to bidirectional when issues with fiber cables , do you have udpd enable on port? it seems in this event is because of speed synch does not match the other side.

glen.grant Wed, 09/26/2007 - 15:59

Don't know if I agree , i don't see anything in the ISP config that shows it is hardcoded , how can the interface be anything other than 1000 full it is a 1000 base X port. I think it shows 1000/full because thats what the interface is a 1000 base X port and would not show anything but 1000/full . Usually cisco devices auto negotiate fine these days. Myself i think it is set as auto, maybe someone else can chime in ...

Peter.D.Brown Fri, 09/28/2007 - 11:34

Thanks for the reply guys. I think the switches, however they're configured, are ok. The speed I was getting has increases mysteriously by 40% after I'd told the service provider. Maybe they've done something and not told me, maybe not. I don't think the link from us to them was to blame though. Spent far too much time investigating anyway and as it's ok now and it's not easy for me to take the Internet link up and down to try things I'm going to leave it as it is.

Thanks again



This Discussion