CatOS - setting portvlancost back to default

Unanswered Question
Sep 26th, 2007
User Badges:

I inherited these switches with portvlancosts specified. I would like to


set spantree portvlancost 5/1 cost 3099


I would like to set these to the default 19 - easy enough. But I also don't want this line to appear in the config any more like it does you fire up a new catos switch.


I tried

"clear spantree portvlancost 5/1 cost"

but that's giving me

"Usage: clear spantree portvlancost <mod/port> <preferred_vlans>

(preferred_vlans = 1..1005,1025..4094)"


Anyone got the secret?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Pari Thiagasundaram Wed, 09/26/2007 - 15:40
User Badges:
  • Silver, 250 points or more

If 5/1 belongs to VLAN 10,


then issue the command :

clear spantree portvlancost 5/1 10


Hope this helps.

mmedwid Wed, 09/26/2007 - 15:51
User Badges:

Thanks for the reply and idea to try. But the line is still in the config. Hmm.


Note from config:

set spantree portvlancost 2/7 cost 19

set vlan 300 2/2-48


So the cost is 19 and the port 2/7 in this instance is on vlan 300.


I run:

c4006-1> (enable) clear spantree portvlancost 2/7 300


Port 2/7 VLAN 1-1005,1025-4094 have path cost 19.


But alas show config shows the line is still there.

sho config

(blah blah..)


set spantree portvlancost 2/7 cost 19


glen.grant Wed, 09/26/2007 - 15:40
User Badges:
  • Purple, 4500 points or more

Did you try entering it without the "cost" statement at the end , that may default it .

"clear spantree portvlancost 5/1

mmedwid Wed, 09/26/2007 - 15:49
User Badges:

Leaving off cost catos prompts me for preferred vlans..


c4006-1> (enable) clear spantree portvlancost 2/7

Usage: clear spantree portvlancost

(preferred_vlans = 1..1005,1025..4094)

mmedwid Wed, 09/26/2007 - 16:23
User Badges:

This is catos. No copy run start here.

Kevin Dorrell Wed, 09/26/2007 - 17:44
User Badges:
  • Green, 3000 points or more

If you take a brand new switch and do show config all, what do the portvlancost look like?


Kevin Dorrell

Luxembourg


Pari Thiagasundaram Wed, 09/26/2007 - 19:03
User Badges:
  • Silver, 250 points or more

If you run set spantree uplinkfast disable on a switch, the UplinkFast feature is disabled, but the switch priority and port cost values are not reset to the factory defaults. To reset the values to the factory defaults, enter the clear spantree uplinkfast command.


http://www.cisco.com/en/US/docs/switches/lan/catalyst4000/7.5/command/reference/set_s_z.html#wp1024720


Actions

This Discussion