Loading IOS onto a 2811 router

Unanswered Question
Sep 27th, 2007

I have a 2811 that I want to load the 'c3825-advipservicesk9-mz.124-15.T1' IOS onto. However I get an error saying the IOS is too big for the TFTP server (50M). Next issue is that I dont have a Cisco USB key do nor do I have another router to load it from...any ideas on what I need to try next?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Thu, 09/27/2007 - 15:20

You could either use a TFTP server that supports files sized larger than 32 MB or use a FTP server.

changezi1 Fri, 09/28/2007 - 20:15

I just used a Compact flash adapter, plugged the CF card in my laptop, dragged and dropped the IOS image file.

MATTHIAS SCHAERER Fri, 10/05/2007 - 09:04

Niall,

do you really want to load the c3825-advipservicesk9-mz.124-15.T1 on a 2811? This is probably no good idea, you'd rather need a c2800nm-adventerprisek9-mz.124-15.T1.bin instead. But I assume it was a typo. I tried to load the c2800nm-adventerprisek9_ivs-mz.124-15.T1.bin to a 2811 from usbflash but during booting I got the error message that the file is to large for booting (whatever this means on a router with 256MB RAM...). The router ended up in a boot loop. There must be something in ROMMON that prevents the router from loading the file. I have not found out yet what it is.

Cheers,

Mat

cisconoobie Fri, 10/05/2007 - 10:58

I have a 2811 and I used that image. Install tftp32 from http://tftpd32.jounin.net/

Since that image was too big to fit on the 2811 flash along with the other image, I had to delete the running image from flash and then I transfered the new image to the 2811 and reloaded it to boot from this new image and it worked fine.

Actions

This Discussion