Routing Protocols problem

Unanswered Question
Sep 28th, 2007

I mentioned the problem i had until today with the speed of one leased line connection 64 Kbps. It was very slow and it was loosing packets. On both routers main and remote run two protocols . RIP v2 and EIGRP . I removed the EIGRP and the problem was solved!!!

Why this is happening?


PC. Meantime in most of the routers the same protocols are running. RIP distance 120 and EIGRP distance 170. I am trying to micrate from RIP to EIGRP without stop the network. The others connections do not seem to have any problems.

Thanks

moses

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Kevin Dorrell Fri, 09/28/2007 - 02:37

It sounds like you had a routing loop. When you had EIGRP on the link, were all your EIGRP routes "active"?


I think you will have to draw us a diagram to work out what was happening, as well as your configs. Did you have both protocols on the other links as well?


Glad to hear the problem has been identified, at least.


Kevin Dorrell

Luxembourg


moses12315 Fri, 09/28/2007 - 02:55

Yes you are right. Because the previous guy was using a lot of different ips in a private network (10.0.0.0 , 172.0.0.0, 192.0.0.0 etc. Do not ask me why) i had do configure the EIGRP 0.0.0.0 255.255.255.255..

And yes i have also those protocols active on some routers. Of course it didn't seem to have a problem there but you never know.

Thanks

moses


PC. I am trying to change all these ips to 10.0.0.0 but that needs time and i do not want to stop the network even during the night.

paul.matthews Fri, 09/28/2007 - 04:13

If you would like advice on migrating from one RP to another, it would help if you could give us a diagram of topology. As EOGRP is onvolved, and you have a mixture of "major" networks, I'll make one suggestion "blind"


Turn off auto summarisation.


EIGRP will summarise at major network boundaries. If all your 10 networks are together, and all 172.16 is together etc, it won't be a problem, but if it has been done using 10 addresses for users, 192.168 for servers and 172.16 for WAN links, while that may look nice and organised, that is probably the worst possible topology for otherwise default EIGRP!


How to migrate - there are a number of approaches.


Big bang - turn one RP off and the other on. Only practical on small networks, but has least chance of conflict.


Parallel running - run both. Can needed. Admin distance for the new protocol should initially be longer than the old one. Confirm by checking topology then shorten the AD to bring it forwards. Can be risky, aprticulalrly is summaries are being done.


Phased - this depends upon a suitable topology, but with a hub/spoke type topology you can enable the new RP on the core and then switch off the old and add the new on each spoke in turn. Similarly if one has a network with obvious regions, this may be appropriate. If the network is to carry user traffic at the same time you will need redistribution between the two routing protocols, but that in itself carries risks.


With larger networks a combination may be needed - phased, and either big bag or dual running within the region.


If I am honest,I would be tempted to readdress and change RP at the same time - enabling the new RP for the new addresses, and having a single redistribution point as I work.


I would also be tempted if doing that to look at OSPF, and its area and summarisation features.

Actions

This Discussion