Need a basic config for an 1841 to use ADSL?

Unanswered Question
Sep 28th, 2007

Has anyone managed to get an 1841 with the ADSL port to get on the Internet? I have connected but get no web pages.

Here are parts of the config I use:

ip dhcp pool client

import all

network 172.19.16.0 255.255.255.0

default-router 172.19.16.1

lease 0 2

interface ATM0

no ip address

no ip unreachables

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

cdp enable

interface FastEthernet0/0

ip address 172.19.16.1 255.255.255.0

no ip unreachables

ip nat inside

ip virtual-reassembly

hold-queue 100 out

interface Dialer1

ip address negotiated

no ip unreachables

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password 0 123456789

ppp pap sent-username [email protected] password 0 123456789

ppp ipcp dns request

ppp ipcp wins request

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip nat inside source list 102 interface Dialer1 overload

access-list 102 permit ip 172.19.16.0 0.0.0.255 any

dialer-list 1 protocol ip permit

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
whiteford Fri, 09/28/2007 - 06:46

Thanks!

What I did notice was though if I ping from the routers console say www.google.com it would resolve successfully. From a laptop it won't but will if I put the IP of google's website in. I thought the import all option in DHCP would get the user to use the ISP's DNS servers?

Danilo Dy Fri, 09/28/2007 - 07:02

Hi,

In your laptop MS-DOS CLI, execute "ipconfig /all" and check if you have a DNS. If none, follow the guide to include the DNS in the DHCP.

Can you check also the output of "show ip dhcp import" from the router if it returns with a DNS entry?

Regards,

Dandy

whiteford Wed, 10/24/2007 - 14:04

Hi, how far have you got, mines all working. All I had to do was add an Internet DNS server IP in the DHCP part.

Can you PC get onto Google by the IP, 72.14.207.99?

If so then its a simple DNS issue mentioned above.

Please rate this post

abelardo.gonzalez Wed, 10/24/2007 - 14:09

Man the issue looks very similar but instead a DNS ip address I just put this command on my internal interface ip tcp adjust-mss 1452 and this command on my dialer interface mtu 1492, then everything works!

whiteford Wed, 10/24/2007 - 14:18

Great, where did you get those settings from? It worries me that never set these mtu settings, everything works, but I wonder if things would be better if I did?

Actions

This Discussion