CallerID dissapears when transferring outside call

Unanswered Question
Sep 30th, 2007

In CCME 4.1

When a call comes from fxo

operator answers

callerID appears

then operator transfers to any ip telephone, it shows operator telephone#

instead of outside callers.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rsefer Sun, 09/30/2007 - 08:56

Here is my Config



!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone TT-YENiSEHiR

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar opx 3000

shutdown

description 4685000

station-id name 4685000

caller-id enable

!

!

ephone-dn 1

number 3000

label 4685000

name Line1

corlist incoming user-longd-gsm-int

!

!

!

ephone 1

device-security-mode none

video

mac-address x.x.16CC

username "xxx" password xxx

type 7931

button 1:1 2:2 3:3 4:4

button 5:5 6:6 7:7 8:8

button 9:9 10m16 11m17 12m18

button 13m20 14m21 15m22 16m27

button 17m28 18m30 19m32 20m37

button 21m39 22m41 23m44 24m24

!

!

!

ephone 2

device-security-mode none

video

mac-address x.x.525B

username "xxx" password xxx

type 7906

button 1:23

!

!

!


Paolo Bevilacqua Sun, 09/30/2007 - 14:08

This is happening with recent CME and I'm not sure if there is a bug filed, or a configuration workaround. The correct behavior is to show both the caller and the transferrer number so one could tell right that is receiving a call for transfer.

If it is as issue for (I guess it is) please open a case with the TAC. Eventually, we can go back to find the last release were this worked as supposedly has to.

rsefer Sun, 09/30/2007 - 23:39

It is exactly the same situation.


I am using latest IOS

12.4(15)T1


I can return back to previous IOS

Which one is rigth?


THANKS



rsefer Mon, 10/01/2007 - 13:01

I think this not reletad on IOS


Ephone-1 is the operator phone (making-transfer)


If I assign one externel line to it

as follows, ther is no problem, callerid is displayed on transferred phone display.

ephone 1

device-security-mode none

video

mac-address 001B.D4C7.16CC

ephone-template 2

username "xxx" password 111

type 7931

button 1:1



If I assign more than one button

callerid is not displayed, instead transferring telephone# is displayed (3000)


Paolo Bevilacqua Mon, 10/01/2007 - 13:41

Good find, in fact I wasn't able to define a past IOS that worked, I may just have seen the correct working on a phone with only 1 button configured.

Still a bug in my opinion and I will open a case as soon as practicable.

m-ketchum Wed, 11/07/2007 - 23:43

Have you had a chance to open a case on this? Is there a case number published?


Thanks much.

Actions

This Discussion